Community
OpenEnergyMonitor

Community

Install pixel desktop gui on emonsd

emonsd
desktop
Tags: #<Tag:0x00007f1be5cf1dd8> #<Tag:0x00007f1be5cf1c98>

(Ernest) #1

Hi,

I am trying to install pixel desktop gui on emonsd, and vnc server. I want to use emonsd pi to connect from the exterior of my lan and check somethings od the lan and the home.

I installed the gui with this comand:

> sudo apt-get install raspberrypi-ui-mods

Then I go to raspi-config and enable vnc server. It works ans emoncms works fine too, but I have to manual start vnc server when pi restart. Why it don’t autorun?

Do you think that pixel desktop will harm emoncms performance?


(Brian Orpin) #2

That is a question for another forum I expect.


(Ernest) #3

Thanks Brian,

I ask it here because I think that emonSD have some configuration that block some apps to load on startup. Because I installed vncserver and I have to run it every time, and the samething with openhab2, by default when I reboot the pi is stopped, when I run it works fine, until next reboot.


(Glyn Hudson) #4

What version emonSD are you running? Ir your running the latest emonSD30Oct18 built then install should be straightforward, although I have no experience of pixel desktop myself. emonSD-30Oct18 is based on Raspbien Stretch Lite.

Should not make any difference, Emoncms is lightweight and the RasPi3 is powerful.

There is nothing in emonSD to block apps at startup.

The only way an app night not run is if it requires a folder to be created in /var/log. Since /var/log is mounted as in memory tmpfs on emonSD, after a reboot all the contentents of /var/log/ is lost. We used rc.local to re-create the required folders on bootup Some services will make their own log files/folders if they don’t exist.


(Ernest) #5

Thanks Glyn,

I am using emonSD30OCT18. I got OH2 running at startup with this code:

sudo systemctl start openhab2.service
sudo systemctl status openhab2.service
sudo systemctl daemon-reload
sudo systemctl enable openhab2.service

And now, vnc server is also running at startup. :thinking: I don’t know why, but it works.