Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Install emoncms in synology NAS

Hi:

I have emoncms working well in a synology running DSM 6.2. I follow this guide: Set up of emoncms on Synology DSM | Archived Forum

The problem is that i want to update to DMS7 and DSM7 does not support MariaDB 5 (only MariaDB 10).

I’ve tried to migrate the databases from MariaDB5 to MariaDB10, even a clean install of emoncms running only MariaDB 10, but with no success.

I always end up with the same authentication error message and “Check your settings.ini file” message.

Anyone tried to make this work with success?

Regards

Jose
I also have a Synology NAS running DSM 7. When you get your problem resolved I would very much like to get the install instructions from you as I would like to add EMONCMS to my NAS.
Regards
John

Hi:

For know the solution i found is to use Synology Virtual Machine Manager to create a Ubuntu 20.04 server virtual machine and install emoncms on it :wink:
It might not be the perfect solution, but it works ok and it does not requires many resources from the NAS. Also it’s future proof and portable between systems.

To install emoncms on ubuntu i followed this guide: Install Emoncms on Ubuntu / Debian Linux

The only error is on this line:

cp default.settings.php settings.php

instead of default.settings.php, the file is example.settings.php

Regards

That is 4 years old - much has changed.

I would suggest using the scripts GitHub - openenergymonitor/EmonScripts: Emoncms Stack Installation and Update scripts

It should be using the ini files, not the php versions.

It also illustrates the danger of using third party sources of information that have not been updated, and which we have no control over.

Yes, it’s the .ini files. You are right. Anyway, it worked ok. The only problem was when i tried to migrate the database from the “old” system (i’m still using DSM 6.2). Since the old system uses a previous version, that did not worked well.

Anyway, since it’s possible to make snapshots of the VM, it’s easy to recover the working state. The problem is that i did not made that, since I’m still doing experiments and did not done the snapshots :rofl: :rofl: