Community
OpenEnergyMonitor

Community

Inputs to emoncms

Tags: #<Tag:0x00007fc9163ddfb0>

Hello again,

I now have my heat pump board working and receiving data on my pi whit emoncms.

Also have 3 emontx working and sending data to the emoncms.

On the heat pump board I have 3 CT sensors, a Kamstrup Mbus, a pulsmeter and a temp sensors connected.

The heat pump Wi-Fi is connected, but the MQTT server keeps saying connected: No

On the emoncms the input view looks good. I see all the value of the 3 EmonTX

Also I see the inputs from the heat pump board.

Looking to the result my heat pump has a COP form 41. That would be very nice but can’t be true.

In the emonhub log I only see the information (MQTT) from the EmonTX, the EmonTX using node 13, 14 and 15. When I update the emonhub, the config file becomes extra node files that collapse whit the MQTT inputs. I have to delete these.

But there are no lines from the heat pump board. In spied these do come in. where can I find these to correct the config values.

I would like to make a serial print and input for the Voltage and Current for each CT to calibrate.

Frans

Hello @Frans

The heatpump board posting via MQTT will not be visible in the emonhub.log as the MQTT data is currently coming into emoncms directly.

It sounds like the key to solving this is to get the MQTT connected status on the heatpump monitor to say: Yes.

Did you enter the MQTT auth details and IP address of your pi?

The MQTT auth details are:

port: 1883
username: emonpi
password: emonpimqtt2016

It should look like this:

Hello Trystan,

Thanks for your help.

I have now also MQTT working (saying yes) and inputs coming.

I found out that the signals come to the emoncms on two ways. Direct from emoncms and by MQTT.

I still need to add the 3 CT’s to one feed. My heat pump is 3 faze.

I create in the sketch a new value for serial printing like

“ EnergieMonitor Total = (OEMct1 + OEMct2 + OEMct3 ) “

But the value than is given is not correct. The heatpump takes 3 x 6 A.

The inputs OEMct are round 300.

How can I see the current for each faze. I would like a input created for that. Also for the Voltage.

Then calibrate the CT’s

regards Frans

Hello @Frans, good to hear.

The heatpump monitor firmware is designed for single phase operation, and has only two CT’s enabled by default. You can switch the measurement from real power to apparent power here in order to get around the incorrect real power readings on phase2 & 3 if you like: https://github.com/openenergymonitor/HeatpumpMonitor/blob/master/Firmware/Arduino/HeatpumpMonitor_AutoTemp_MultiPage/HeatpumpMonitor_AutoTemp_MultiPage.ino#L453 you will need to add in the 3rd CT though as well.

Alternatively and more recommended is to use the 3 phase firmware on the EmonTx: https://github.com/openenergymonitor/emontx-3phase

Won’t the heat pump present a balanced load - in which case only one current measurement (hence only one real power) will be needed?

Good point! Is there a chance the heatpump controller board and central heating pump could be on one of the phases and then the main compressor across all three?

Given that the CT inputs on the heatpump board are intended only for indicative power monitoring the error might not matter that much - for higher accuracy monitoring with the heatpump board I recommend using the pulse input or Elster A100C IrDa reader (though that’s a single phase meter - I couldnt get the Elster A1100 3 phase meter IrDa to work)

The “ancillaries” probably are single-phase, and they’re probably not that significant in relation to the compressor. But without knowing the powers and power factors, it’s impossible to say with certainty. However, with the pump being around 10% or less of the compressor’s rating, then provided you measure the current on a phase that isn’t powering the pump, the result should be reasonable (but low). If you measure the one that is, the result will be high and the error bigger.

1 Like

Trying another way. How do I set the IrDA pulls to an Elec value?