Community
OpenEnergyMonitor

Community

Hovering data point values not showing


(Ari-Matti Husa) #1

A minor peeve. Managed to migrate to my cloud-vps instance. Everything is running reasonably OK, but I have one minor inconvenience. When I look at graphs, the server does not provide data point values when I hover over the graphs with mouse pointer. The values did show on emoncms.org and they also do show on my local emonpi.

Any ideas? I am not too proficient with web server stuff :slight_smile:

BR,

Ari-Matti


(Trystan Lea) #2

Hello @luru, did you install the graph module on your cloud-vps? http://github.com/emoncms/graph


(Ari-Matti Husa) #3

Yes, I checked and even reloaded the Graph module. Got the extra visualisations, but I reckon the module should also replace the default graphs (if there ever was any)? I remember always having the Graph option in the menu, don’t know if I just have installed the module anyway.

But no hovering values yet. Gotta dig deeper, I guess…


(Anthony Vassallo) #4

I had the same issue for the last 6 weeks or so, but updating the database through setup -admin fixed it instantly. I did try git clone but graph already existed.


(Eduardo Rodrigues) #5

I have this problem too, it starts after update to 9.9.0 (I think it was at 9.8.30 before) and already update to 9.9.2 and still have the problem.
Already try with different graph, different dashboard and still not showing!
I noticed that it just happens in the dashboard, if I open the graph in the “graph editor” it works fine.
Any suggestion?


(Trystan Lea) #6

I think this issue may be related to the addition of units in 9.9.0. Does a database update and browser cache reload fix it for you @eduardofsr @luru?


(Eduardo Rodrigues) #7

Database update just return: Database is up to date - Nothing to do
Already tried several browsers and computers…


(Ari-Matti Husa) #8

Still not showing. Haven’t had time to experience that much, but of obviously emptying cache and updating database did not help.


(Ari-Matti Husa) #9

Mine does not work even in the editor :slight_smile:


(Ari-Matti Husa) #10

Update: After updating to latest emoncms and graph + dashboard modules as well, hovering values show in graph editor now. Not in dashboards, but I don’t know if they ever have. I am happy.


(Nuno Faria) #11

i got the same problem, that hovering on Dashboard is not working. however hovering is working on Graphs
Refreh and anonymous windows didnt solved. CTRL-F5 didnt solved this time.
error is : Uncaught ReferenceError: moment is not defined


(Ales Sko) #12

Well, I was noticing the same thing with my emoncms 9.9.4 after I did upgrade from quite older release.

I noticed same Reference Error as @nuno_faria1 described above, and compared the Console output between working Feeds graphs and non working Dashboard graph.

This fix worked with me, hope others will also have positive results:

  • edit file /var/www/emoncms/Modules/graph/embed.php
  • add below line just after graph.js (you will find that on line 66 of file)
<script language="javascript" type="text/javascript" src="<?php echo $path;?>Lib/moment.min.js"></script>

…so it looks something like on the snapshot.

Reload the page on your browser and things should work. Fix is persistent across reboots.


(Nuno Faria) #13

Thanks… working like a charm :smiley:


(Trystan Lea) #14

Thanks @ales-sko for finding the solution. I’ve updated the graph module with your fix: https://github.com/emoncms/graph/commit/a2057097a5e2be32992832b15908b665405ed18b, much appreciated!


Dashboard graphs cursor problems