HomeAssistant emoncms component not sending to emoncms.org

Would you mind sharing your Emoncms config? I have set up emoncms_history component in HA but am not familiar with the Emoncms side of things.

I added Emoncms History to my HA after I saw Glyn’s post above.

I followed the notes provided and sent to node 19 as I hadn’t used it before.

I had to do nothing in emonCMS itself to receive it, but then I just added some basic logging to create the feeds I required.

Hope this helps.

I had created the same in home assistant but saw nothing in emoncms

When you said you added some basic logging, did you have to create an Input?

If so, what device template needs to be chosen and do the location and device key fields need to be filled in?

I didn’t have to create any inputs, they just appeared when HA sent the data.

The only difference is my url is local, non-https i.e. http://192.168.1.x

Is it the Read/Write API key?

Any errors in the log?

Don’t worry about the ‘Devices’ bit. They should just appear in the Inputs as Node 19.

Yes, it’s the Read/Write API key. I’ve checked the home assistant logs and there doesn’t appear to be anything related to emoncms_history.

Am I understanding correctly that no configuration should have to be done on the emoncms.org side and the data should just “appear”?
Would the fact that I have Cloudflare access set up for home assistant have any impact?

Did you restart HomeAssistant?

I did once I made the change to the configuration.yaml file

1 Like

Anything in the logs?

You can increase the logging for a specific component (I don’t use the emoncms component)

  default: warn
    homeassistant.components.emoncms: debug

Check the log on startup that homeassistant.components.emoncms is the correct component name.

@bwduncan - anything you could point to?

Should be homeassistant.components.emoncms_history but the component doesn’t have any debug logging so I’d be surprised if the answer is there. It does log errors which you would see without configuring logging explicitly.

One thing to double check is whether the states you’re exporting can be represented as numbers. emoncms can only process numbers. The HA integration tries to convert everything to a number, so this can’t really be the problem, but it’s worth a look.

Double check API key

1 Like

As above, once the node was initialised in EmonCMS I didn’t have to do anything to see the data in my Inputs screen.

I did have to change the names in the Feeds screen as the ‘.’ character is not allowed

I have checked the HA logs and there is nothing relating to emoncms_history in there after a restart or after it has been running for a while

I only included one sensor as a test and it is a numeric value in HA. I also used a new inputnode.


I double checked the api_key and it is the Read & Write API key

I am still not seeing anything on the Inputs page unless I’m missing a step?

Possibly (or perhaps probably). Depends on how you have done it, but yes that could affect it (but don’t know how or how to fix).

It must be something to do with your setup. You can try the API Helper to create an input from your browser to prove it works outside of HA.

That worked so it must be an issue with the HA process

Are you sure it’s not within another ‘block’ of some other code? Try moving it to the top of your config.yaml

It definitely wasn’t but moved it to the top and restarted just to test. Still nothing in HA logs or Emoncms.

Apologies, I have it working now. I think it was caused by an issue in Studio Code when I moved over to Cloudflare. I reinstalled Studio Code and now the data is coming into Emoncms.
Thanks to everyone who offered assistance.