Community
OpenEnergyMonitor

Community

Help with an error passing data from IotaWatt to influxDB

influxdb
Tags: #<Tag:0x00007f1ff2a82000>

(MarkM) #1

Can anyone point me in the right direction, I can’t seem to get data from the IotaWatt to InfluxDB (local)
This is the error in the message log:
influxDB: last entry query failed 200 expected field argument in last()

Any help appreciated.


(Paul) #2

The IoTaWatt forum may be a better place to ask a question that is specifically about the operation and use of IoTaWatt. That is managed by Bob Lemaire, its creator, and he and the other users there are more likely to have the specific knowledge to help you.


(MarkM) #3

Hi Thanks Paul.
LOL …This was what came through with the IotaWatt invoice:-
For support please post on our Community Forum: https://community.openenergymonitor.org.

I shall join the other forum immediately - many thanks.

Mark


(Paul) #4

Ahh!

To be fair that is a general statement and we can help with emoncms stuff, OEM hardware, generic energy monitoring and try to assist with any energy monitoring equiptment when we can. But there is a specific forum for Iotawatt where you can get more specific assistance.

I will bring this to the attention of the shop but I’m not sure they can change it for just one product. The Iotawatt page does give the iotawatt forum link though.


(MarkM) #5

Hi Paul, yes already been through the docs- and google and I couldn’t find anything in either on this error- hence the need to post.
I’ve joined and tried to post on the other forum (thank you for the link) but it says ‘Account temporarily on hold’ - I guess its because I’m a new poster…No such issue with this forum.


(Paul) #6

Yes, we have the same filters (not sure about any settings though) as the forum software is Discourse on both sites. Perhaps set up a little stricter over there?

OEM kit and emoncms do not ordinarily use influxdb although a few users do use it, so assistance here would be minimal and without in-depth iotawatt knowledge, fairly general.

You are welcome to post here on any relative point (incl Iotawatt or influxdb) we just think you would get more specific assistance over there (once your post is out of quarantine!)


(MarkM) #7

Thanks Paul,

I’m keen to see what comes back from the IoTaWatt forum post when it’s approved for publication.

Meanwhile if anyone on this forum has any insight into the:-

‘influxDB: last entry query failed 200 expected field argument in last()’

error- it would be great to hear back.


(Bill Thomson) #8

Hi Mark,

An error code of 200 usually means a malformed Line Protocol request.

The error is telling you you’re missing one of the arguments. Specifically the field associated
with the “last” selector.

image
In the screenshot above, the field associated with the “last” selector is named “value” but it can
be named anything you like.


(MarkM) #9

Thank you Bill -
I removed all ‘tag set’ and ‘measurements’ - and still got the same error
changed the port to force a failed connection and IoTaWatt remained ‘running’- (previously stopped immediately)
on the config screen removed ‘measurement’ and ‘field-key’ names so they were back to default $name and value + corrected the socket and we are now running!
and influxDB “show measurements” now returns data

Very happy

Thank you Bill


(Bill Thomson) #10

Sounds good! thumbsup