Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Help reviving an old setup

Hi, my setup (somewhat underutilised, I’ll admit) has been plodding along doing its thing for about 5 years but when I went to check the other day after a power cut it looked like it was toast. I assumed SD card corruption since the lights and screen still worked.

I am running a Pi 2 B (I think) and it seems that the latest image to support that without issue is the one from 2017 (Jesse-based). So I flashed that on the card and plugged it all in again.

My first issue seems to be that the unit just displays its “DO NOT UNPLUG” updating message for what seems like forever. As far as I can tell it’s not updating. I can SSH into it at this stage so the Pi is alive.
When I eventually reboot it manually something bad has happened since it won’t get past the “Raspberry Pi Booting” stage. I have tried this several times with the same result.

When plugging in an HDMI cable to the Pi, I get no signal. Is this because the video out is disabled while the emonpi board is connected?

Any advice as to how to get back up and running (hopefully without having to splash out on a more recent version of the RPi) gratefully received.

Nope. I’m running the present stable version ( Version low-write 10.4) on a Pi 2 B (Raspberry Pi 2 Model B Rev 1.1 - 1GB - Sony UK) with an 8 GB SD card. Shrinking the 16 GB image to 8 GB was a pain but relatively straightforward.

Here’s how:

I followed that from the heading:

Shrinking images on Linux

to the bottom. Where it states:

Now notice a few things:

  • There is one partition.
  • The partition allocates the entire disk/device/image.

That’s not correct, it showed all the usual partitions. At that stage, I used GParted to resize the 10 GB partition only, down to not very much (i.e. so that the total was well below 8 GB), then finally, when it was on the 8 GB SD card, expanded it again with GParted to fill the card.

I can understand why the image was made as 16 GB (except I could only get a 32 GB locally), but it’s an awful lot easier to expand the partition than shrink the image.

I would suggest you don’t stay with the 2017 version, it won’t update to the present version from that.

I’m not sure of a route to recover your old data though - but you’ve probably lost that anyway when you reflashed the card with the 2017 version.

There’s only one problem with the Pi 2B - it’s S L O W when you’re drawing a year’s worth of graph.
Otherwise, I haven’t noticed any problems (and it’s presently running the upcoming emonPiCM front end software).

2 Likes

Thank you very much. I’m back up and running again based on your recommendation to use the latest stable image. The reason I didn’t use it initially is that Pi 2 is not listed as supported.
Fortunately I didn’t need to shrink the image since I had a 16GB card.