Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Help please, it's all gone wrong

Tags: #<Tag:0x00007fe7a70776f0>

I was writing a post to ask for help (I’ll leave that query at the bottom) and whilst trying things everything went wrong. I plugged, what I’m 95% sure, was a comms wire back into the module that I was testing (already connected to a cell) and puff the Wemos chip let out the magic smoke, never to be put back in again. Damn, nevermind I have another fresh one. Got that sorted and programmed and then plugged it back into the other modules, but now I’m not seeing any comms at all between module and controller.

OK, I’m going to write as I test, as this has got even worse.

So I sorted the issue above, by trying different jumpers. I gradually added in modules. As I added the third module in, this time 100% checked the correct cables are used, it just fried the second wemos. More smoke, game over.

How is one of my modules passing voltage into the comms lines? There’s no obvious issue with that module, it still is giving me a blue double blink.

I’ve just checked with my DMM and the RX1 port is showing full cell voltage of 3.43V!

So that’s what destroyed my 2 Wemos boards. I didn’t even build these modules, I got them from the OEMon store.

So first thing I need to do is condemn this dangerous module. Is there any testing I can do that may help track a potential fault issue with other’s boards? I’d be willing to post it to @stuart if it would be useful to look at.

The second thing I need to do is order some more Wemos D1 Pros.

Thankfully I ordered another set of modules from JLC PCB as I’m thinking of adding more cells to the battery I haven’t built yet (don’t ask!).

So here is the original issue I was trying to solve before all of the magic smoke started to fly:

I’ve got four modules (erm, not any more!) and one controller (now missing the Wemos d1 pro). I have had all modules running fine before today (how ironic).
I’m still in my testing phase. So I’ve just got 4 18650 cells in a holder that I’m using to power a router. Each cell has a lead with a JST for a BMS module.

One of the cell modules has stopped working (not the one that just fried the Wemos boards). It immediately goes into Bypass when I plug it in and there is no communication beyond the module. And all other comms fail. I have tried plugging it in to the controller on it’s own, but no change.

I tried plugging it into my laptop, but as soon as I connect it to my USBASP I get a warning message from windows saying USB Device Not Recognised. When I try and program through Platform IO it fails because it can’t find the board. When I unplug the board from my USBAPS the programmer reappears in the device manager.

What am I doing wrong? Just how many things can I bugger up in one day. Any help, whiskey or condolences gratefully received!

Hi @Ian_Jordan

We all let out the “magic smoke” now and again !

However, back to the problem.

The modules use the full cell voltage as part of its design, thats okay, as it will never be above 4.2V.

The pin 2 of the RX1 connector will be at the cell voltage, pin 1 at the negative of the cell.

First of all, you need to wire up the modules from TX to RX and so on - never from TX to TX and RX to RX !

The blue LED blink occurs when the module has not received communications for over 8 seconds. Its just the module automatically waking up and checking the voltage of the battery cell its connected to. Thats normal.

So could wiring TX to TX cause the Wemos to blow?

No I don’t think it should, but RX to RX definitely releases the smoke.

1 Like

OK, that sounds like what I must’ve done, twice :sob:

So then onto the other issues I was having, why was the one module not working properly?

Also, I went to have a play with my Relay rules and there was a message saying something about the chip not being there to allow relay control, what’s that about?

Is the PCF chip soldered on to the controller ?

It sounds like you are running an older version of the code, time to upgrade.

Hmm, I’m sure I downloaded and installed the latest last month. I hope the PCF chip is there, I bought the controller from the OEMon shop. It certainly looks like it’s on there.

I’ll clone the git again once the new Wemos board turns up.

Ok, follow the programming instructions from here - no need to use platformio…

Stuart, thanks for the help. Just tried it with the module that wouldn’t work. I don’t understand what I’m doing wrong here. I managed to program these modules previously, now as soon as I plug a module into my USBASP the leds blink for a second, then they all go out and Windows says it can’t recognise the device.

So I got my multimeter out and it looks like the board is trying to bypass, even with the USBASP programmer set to 3.3v. This means there’s a huge voltage drop. When I measure the voltage on VCC/GND with the module plugged in it’s dropping to 1.5v (which makes me think it’s bypassing). Is this happening because I’ve already flashed these boards before? Does that mean they can’t be flashed again?

Definitely not they can be reprogrammed almost indefinitely.

It sounds more like a short, hence the current high draw.

OK, so I have check all four module boards that I have. 2 of them draw all of the current now, 2 don’t. When you plug them into a cell they start bypassing immediately. One of the two that now bypass constantly didn’t do that before the second Wemos fried. Can they get stuck in some sort of bypass mode without a controller? The whole reason for trying to reflash one of the modules was that it wouldn’t stop bypassing or communicate with the controller.

Can you connect it to a single 18650 cell, with a voltage about 3.5v? It may stop balance at that low voltage. Although, its possible the board is fried

I’ll try, although I think I’ve just charged them up! Bare in mind that 2 boards seem to be doing this now. Any idea what could’ve caused it (really want to avoid doing it again if I can!).

OK, so I plugged in a bench power supply. Turning down the voltage did not stop the bypass (I took the down to 2v). I saw the same behaviour with both modules. Are they dead then? Very frustrating seeing as I haven’t even got my battery set up!

Could this issue have been caused by the short that fried the Wemos chips?

Thanks again for all of the help.

Maybe, although if you reconnect the AVR programmer and reflash the code, they may come back to life.

If you can, set the AVR programmer to 3.3v rather than 5v

The problem is the board drawers so much power that the USB voltage drops to the point that the processor wont run, because they are bypassing, when set to 3.3v the voltage is pulled down to 1.5v, when set to 5v the USB socket just shuts down.

I can’t work out how to program the boards whilst they are bypassing.

At 3.3V the board should be pulling about 500mA, well within the capabilities of USB power supplies.

I think you have a dead short on the board. If you unsolder the D1 part, you will stop it going into bypass, but I think the board may be fried.

OK thanks, 10 modules just turned up from JLCPCB, so this isn’t a critical issue to fix anymore.

The next issue to try and fix is why the controller doesn’t think it’s got a relay controller. Unfortunately it’s still going to be a couple of days before my replacement Wemos boards arrive.