Heatpump app configuration in emoncms

Hi all… first post here so hope I’ve not missed something obvious

I’ve self installed (did all the plumbing) a Samsung Gen6 16kw ASHP.
I have the modbus module installed in the outdoor unit, I have an ESP8266 interfaced to the modbus module.The ESP is configured with ESPHOME , it is configured to read the modbus, all the modbus data is then logged into homeassistant sensors. I have flowT, returnT, flow rate in l/min, outdoorT, plus compressor frequency. All so far so good. I also have a CT clamp (again via an ESP8266) on the outdoor units AC power feed, logging kW input into home assistant.
After poking around with trying to calculate and graph COP for a week inside home assistant (I finished the heatpump install last weekend), I realised it’d be saner of me to make use of the work that’s already been done here. so I’ve enabled the emoncms add-on for home assistant, emoncms is running on the same machine now. I’ve configured homeassistant to export the necessary sensors as inputs into emoncms. That’s all working fine. I’ve configured emoncms feeds based on those inputs:
flowT → log
returnT → log
outdoor temp->log
outdoor power input->log
( flowT minus returnT ) times (flowrate) times 0.07 → log (should equal kW heat output)

the numbers that I see in these feeds all look sane to me. so I’m ready to do something with the data.

I’ve enabled the emoncms “heatpump app” as I understand this to be the streamlined way to get a nice COP and such, but I must missing something. I can’t get past the initial configuration screen of the “My Heat pump” app.
I’ve configured the values that I have feeds for, and set the others to disabled. But I only ever get the “delete” button at the bottom, I can’t get to the point of the app running. I’m half expecting a “save” or similar button to appear once I’ve done it right… would that be correct expectation?
here’s what I have:

I did try to RTFM but I can’t find a guide for this stage of the setup… what did I miss?


The two kWh values you have disabled are easy to add, they are just the cumulative value of the power and heat values you are already logging.

On your input where you “Log to feed” ashp_outdoor_power, add another step immediately after to a new feed called ashp_outdoor_power_kwh, using “Power to kWh”.

Similarly, where you “Log to feed” ashp_heat_output, add another step immediately after to a new feed called ashp_heat_output_kwh, also using “Power to kWh”.

Then pop back into the heatpump app and add those new feeds.

You should then be able to run the heatpump app but you will have to wait until a bit of time has elapsed for it to show good stuff.

I think it works with the room temperature disabled.

thanks christian. I (perhaps naively) assumed that those were intended to be “or” configurations i.e. if I gave it a kw input I wouldn’t need to give it the kwh one as well - because it can work that out for itself. having created the two kwh values from the kw values as you suggested, the app configures and runs fine now. It doesn’t need room temp to run (although I can provide it with that).

I have however noticed that with app running for about 15 mins now, its displaying power as though I’m giving it a feed in W, when I’m actually giving it a feed in kW. i.e. the app displays “electric 2W, heat output 7W”.
The feed contains the value “2” and “7” and the heatpump is pushing 7kW and pulling 2kw electric (ish). The app config says it expects power in kW. I could stick a multiply by 1000 onto the feed before I send it to the app - but would that be the right place to fix it ? why does the app config expect a “kWh and/or kW” value but then display in W?

edit - my bad. having looked again, it expects power in W but energy in kWh. so it appears one does need to put in the x1000 for the power.

Yes; for energy monitored by an emonPi or emonTx, the norm is to Log to Feed in Watts to store the detailed usage then use Power to kWh to store the running total.

thanks. that wasn’t obvious to a first timer. as I am coming from a sensor in home assistant thats in kw (albeit to 3 decimals so its still got the per-watt resolution).
its working now and looks right. just wait for meaningful data now.

1 Like