Community
OpenEnergyMonitor

Community

Getting started EmonCMS on a PI3 and EmonESP


(Cassie) #1

So I loaded EmonCMS on a PI3, and EmonESP on a NodeMCU. Firstly how do I setup EmonCMS with nodes and feeds? Most of the guides are based on EmonPI and EmonBASE and it appears nodes are auto-detected? Secondly, how do I get EmonESP to connect to the PI? They are both on my wifi network, and imputing the EmonPI IP (settings) does not seem to work (I am guessing I need to first setup a node with a access token?)


Diy - software needed?
(Brian Orpin) #2

Do you mean the EmonESP firmware onto a NodeMCU?

If the data is passed to EmonCMS in the right format, EmonCMS will automatically create Inputs. You can then set up processes to porcess that input into a feed. Do you have any inputs?

Have you setup the WiFi and configured the API key etc? This item might help (from the shop page).

I’ve no experience with the EmonESP directly.


(Cassie) #3

Do you mean the EmonESP firmware onto a NodeMCU?

Yes I flashed EmonESP onto a NodeMCU board (Working and connected to my wifi) - just not connecting to the MQTT server or to the Local EmonCMS Pi3 (When saving the config, it does not say connected?)

Do you have any inputs?

I tried setting up nodes and inputs, but was not sure if there were done correctly.

The link you provided might help in this regard…
I will give it a try and see if it solves my issues.

If I get the EmonESP to send data to the local EmonCMS server (EmonSD) - and send the correct data, will it create the inputs? (I only need to setup a node?)


(Brian Orpin) #4

Yes, if the data is received correctly the inputs ‚Äėjust appear‚Äô.

Try changing the log level in the settings.php file to INFO level and then check the log (set it to autorefresh) in the EmonCMS admin screen. If you have the wrong API Key for instance you will see an error.


(Cassie) #5

Still no luck




(Cassie) #6

So sent some test data from MQTtLens and this appeared on the EmonCMS…
Looks like the problem is with the EmonESP then - not connecting?

Am I correct in saying the mqtt message must be
Topic
emon/NodeName/ct1
emon/NodeName/ct2
emon/NodeName/ct3

Payload
Value in watts (Must I include a W?)


(Brian Orpin) #7

Just as a note, you can use the button to copy the log as text, and then paste it in a message. If you do prefix the output with a line of 3 ‚Äėbackticks‚Äô (the top left of the keyboard) and 3 more on a line of their own at the end of the block.

It seems you have an emonhub configured but I suggest there is no emonhub installed. @TrystanLea can you confirm what the setup should be for an EmonSD image without an RFM module please?

Yes and no. If you look at the examples in the API docs (from the input page) you will see you can also send JSON data.

Payload must just be a numeric value. Can be temperature, humidity, power, volts - anything that is numeric.


(Cassie) #8

Ok so after struggling for hours again yesterday, I decided to load Tasmota on D1 mini and see if I can get it posting using mqtt. To my surprise it to couldn’t connect. So after some tinkering I got to the router… I setup a parental control on most of my connected devices to limit data usage during metered hours. Turned out the router was blocking all devices not on the same parental control group from seeing them - go figure…

So got everything working as intended now…