Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Getting openevse wifi upgrade working

Tags: #<Tag:0x00007fc9af63fb48> #<Tag:0x00007fc9af63fa30>

I have an OpenEVSE v2.5, which I have added the ESP8266 to. Loading current firmware to the Openevse and ESP8266 went smoothly. I got the ESP to connect to my WIFI.
However now I’m a bit lost!

Currently the OpenEVSE is displaying a client IP address which I think is the emonpi, 192.168.0.16.

How do I connect to the web interface to use the charger? Are there any other settings I need to change on the emonPi?

thanks!

If you enter that IP address as the URL in you browser, it should serve up the web pages for you.

I can’t see the pages to control the openEVSE, I get the wireless config page.
However the wifi seems to be working as data is appearing as inputs in “openEVSE emoncms”.

That sounds strange.
Are the inputs into emoncms definitely updating? I think it should be every 30 secs.

I’m wondering if I’ve got a poor wifi signal to the openEVSE, so perhaps I should get that sorted before wasting any more of your time!
Seems to me there’s two issues; not seeing the web pages served by the ESP, and then some emoncms issues…

  1. Still getting the wifi login screen, when I browse to 192.168.0.16. Does this point to an erratic wifi connection?

  2. On data.openevse.com I see this - which I suspect is also not quite right.



    Am I right in thinking that I shouldn’t have 2 sets of inputs, that one set is being updated (named openEVSE*) - but the first set is getting processed into Feeds?
    Should I manually set feeds from the inputs named “openEVSE*” , and then delete the others?
    Thanks!

Unfortunately, this has strayed outside my limited area of expertise. Hopefully @glyn.hudson will be along shortly to assist.

1 Like

I tried a WIFI signal repeater yesterday, and connected the openEVSE to that WIFI. Still getting the same symptoms- no openEVSE web pages served, only another WIFI connection page. I did notice the IP had changed to .0.25 instead of .0.16 however.

Before I try re-doing the firmware, are there any gotchas with the emonPI? Settings I should have changed perhaps?

Thanks!

Sorted - I uploaded the latest firmware 2.7.4 (via wifi!) and now I’m getting somewhere.

1 Like

Ah - hit an issue already - all was good and I was setting things up until I tried to change the wifi. Now the web server is hanging (please wait…). I’ve seen reference to this in some threads, is 2.7.4 the recommended firmware or is there one less susceptible to this?

Also- when I do get it going again- is there an MQTT tutorial somewhere, as I’m new to MQTT and don’t know the syntax for the MQTT feeds!

thanks