Gaps in emoncms updates

Hi

I’m getting quite a few gaps in my updates from my Emonpi to emoncms. Seems to be mainly overnight. The Emonpi is logging correctly every few seconds. See attached output from the emoncms data.

I guess I have 2 questions:

  1. Anyone else experiencing this? Or are there some checks i can do?

  2. Is there a way to setup so emoncms ‘catches up’ with the missing messages from the Emonpi? ie, when the connection is up again, it sends all the missing data?

Pete

Is the data coming from you emonPi or another RF node e.g. emonTx?

Im assuming the screenshot above is from emoncms.org? Are you logging the data locally to emoncms running on the emonpi? If so does the local data have the same gaps? If not the issue could be your internet connection?

Yes, the screenshot is from emoncms.org. The data is coming from my Emonpi. The Emonpi does not have the same gaps, so I guess it could be the overnight internet connection. Is there no way to recover the gaps? E.g. send the data again somehow from the Emonpi?

Pete

I have the same problem but since I always fiddle, was rather convinced I messed it up again.
This is when creating a graph via the graph module as in the normal modules the data is shown without gaps

data coming in via pi’s and then to self hosted emoncms

basically some graphs show gaps when the are basically zero for several hours … so instead going back to zero they stop till next data is not zero (next day mostly)

another feed works sometimes for a day and then not anymore for a week …

Not sure when this started but I think with latest updates from emoncs 9.8.2 combined with latest graph module.

Need to digg deeper as I haven’t yet found any relation why/why not a graph is correctly plotted.

a few screenshots, in the graph module you see sfeeds 72 and 68 as empty though this is not true) and I add details from bat in and out feeds from today … they are not empty or stopped … why ??

That’s interesting…worth keeping an eye on to see if it stabilises

I think I may have discovered my issue - or found another one!

My feed to emoncms.org stopped again overnight, about 7 hours gap. But the emonpi data is all complete throughout that period.

However, although I’ve setup with a static IP address I noticed that my wifi IP address showing on the EmonPI display wasn’t showing my assigned address of x.x.x.5 but a dynamic address of x.x.x.109 allocated IP from my DHCP router. But the static wired IP address was ok (x.x.x.6). I can access the emonpi via x.x.x.6 or x.x.x.109 but not x.x.x.5

I then restarted the emonpi. The IP address on the emonpi display still said x.x.x.109 for wifi but i was able to access via x.x.x.5 again. Ping it, and access via terminal. (I could also use x.x.x.109) ! The emonpi data was now being received in my emoncms.org db too.

That’s really strange, as I’ve setup the WIFI and Fixed IP addresses to be static…here’s my dhcpcd.conf settings at the bottom of the file:

interface eth0
static ip_address=192.168.1.6/24
static routers=192.168.1.1
static domain_name_servers=192.168.1.1

interface wlan0
static ip_address=192.168.1.5/24
static routers=192.168.1.1
static domain_name_servers=192.168.1.1

I have also bound .6 and .5 to the respective MAC addresses on my router.

Any ideas what’s up?

Pete

why do you use /24 after your fixed ip address … there is no need to since you don’t wan’t it to change … or I miss something in your setup ?

I think the /24 is shorthand for a subnet mask of 255.255.255.0.

Sorry I cannot remember the term for the shorthand - must need more coffee! :grin:

EDIT: from wikipedia → CIDR notation
“CIDR notation is a compact representation of an IP address and its associated routing prefix. The notation is constructed from an IP address, a slash (’/’) character, and a decimal number. The number is the count of leading 1 bits in the routing mask, traditionally called the network mask”

i just followed the emonpi setup instructions & copied the ip notation from there.

I think I found those instructions here:

 

Do you use (or need) both ethernet AND wi-fi? If not, try removing the wi-fi config:

interface wlan0
static ip_address=192.168.1.5/24
static routers=192.168.1.1
static domain_name_servers=192.168.1.1

and then sudo reboot the emonPi.
 

This should disappear when the DHCP server forgets about the old DHCP address of 109. On my DHCP server I can delete an old address (like the .109) but I don’t know if that is possible on your DHCP.
 

EDIT: Also enter ifconfig

ifconfig
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.60.230  Bcast:192.168.60.255  Mask:255.255.255.0
          inet6 addr: xxxxxxxxxxxxxxxxxxxxxxxxx Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:119629 errors:0 dropped:2 overruns:0 frame:0
          TX packets:121724 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10642470 (10.1 MiB)  TX bytes:29049196 (27.7 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2882895 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2882895 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:369853600 (352.7 MiB)  TX bytes:369853600 (352.7 MiB)

gonna try switching off wifi and using fixed only, see if that stops the drop outs…will report back

not sure if I found the reason but today I fiddled some more
The feeds coming via the victron pi was sending data every 30 seconds (+/-)
emoncms online expected date every 10s I think though you can’t change it once set … anyway

I pushed my victronpi to push every 20 seconds since noon and the graphs started to show some but

I remade the graph and it still shows gaps when I stay on let’s say day level (remember I fiddles after lunch)

But when I zoom in then suddenly when I leave out the gap period the graph plots (see images)

I have no clue if related


PS : just did the same on another day with gaps, once I zoom in the graph plots correct …


No gaps for me last night. All data went through to emoncms.org ok. So it must have been the wifi dropping. I may try switching off the wired and switching on the wifi to see if it is them clashing, so i can go back to wifi only.