From a rented server to self hosted.. part 2

i now got a basic server (LAMP) setup on my OMV box

i did a git clone:

git clone -b stable GitHub - emoncms/emoncms: Web-app for processing, logging and visualising energy, temperature and other environmental data

and i copied AND CORRECTED my settings.php from the rented server

i do get this error:

emoncms is located in /srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms

the only files where i can find “/var/www/html” are:

[email protected]:~# grep -rnw '/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/' -e '/var/www/html'
/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/Lib/travis-CI/emoncms.conf:1:<Directory /var/www/html/emoncms>
/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/Lib/gridjs/grid-demo.php:145:        $path = '/var/www/html/emoncms/';
/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/scripts/logger/ ln -s /var/www/html/emoncms/scripts/logger/logrotate.conf /etc/logrotate.conf
/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/scripts/logger/ chmod a+x /var/www/html/emoncms/scripts/logger/logrotate
/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/scripts/logger/ ln -s /var/www/html/emoncms/scripts/logger/logrotate /etc/cron.daily/logrotate
/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/scripts/logger/    cd /var/www/html/emoncms && git pull
/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms/scripts/logger/    cd /var/www/html/emoncms/scripts/logger/ && sudo chmod +x

none of those seems like they are config files… is it a hardcoded default because i use the wrong filename for the settings ?

This will never work. As a bare minimum you need a MYSQL server installed and setup for emoncms. There might be other minimum requirements.

There are no manual install instructions, just the EmonScripts.

that is installed… and config file points to it

there used to be but those are gone…

Yes because they were old and not correct. Replaced by the scripts.

they worked fine for me…

so which of the scripts do i use if i do not want it to install any software… ie just getting the config right

When? A couple of years ago?

Well you are trying to install software!!! emoncms is a piece of software!


more than that… i remember there was a install doc for shared servers… for me it was pretty much doing a clone and then change the config to point to the right sql server

Exactly. Things have changed

Nope it is far more than that. It uses a timeseries database and a sql database.

well… i have to figure something out as i only used sql…

What is your base OS? Scripts worked for me on an Ubuntu based PVE Container. Just select what you want installed.

Someone previously dissected the scripts and used the commands - but that is hard work!

omv with a lamp server installed via docker… so i have mysql, redis, webserver and phpmyadmin…

what i meant with software is that i only need to fill in the www dir and get config correct

The install isn’t designed that way and this is highly unlikely to change to support an extremely small user base. You will need to go through the scripts to find out what it actually done.

However, the scripts do check for installed things, so should skip anything it finds already installed.

i manged to move files from the shared server to the local one… of course its pointing to the wrong sql server and i need to change that

but i tried to do a git pull and that failed… do you know how i could fix that so i can update with a simple git pull ?

[email protected]:/srv/mergerfs/Data/Emoncms/docker-compose-lamp/www/emoncms# git pull
hint: Pulling without specifying how to reconcile divergent branches is
hint: discouraged. You can squelch this message by running one of the following
hint: commands sometime before your next pull:
hint:   git config pull.rebase false  # merge (the default strategy)
hint:   git config pull.rebase true   # rebase
hint:   git config pull.ff only       # fast-forward only
hint: You can replace "git config" with "git config --global" to set a default
hint: preference for all repositories. You can also pass --rebase, --no-rebase,
hint: or --ff-only on the command line to override the configured default per
hint: invocation.
fatal: unknown index entry format 0x092e0000

Git really doesn’t like it if you try and move a repository (as that is what this is, a local repository) as it knows where it was and you changed that. No I don’t know how to fix it :frowning: