Feeds marked "Public" not visible

Hi All,
I run my own 10.1 Emoncms server (Ubuntu 17, MariaDB, Apache) and I can’t figure out why flagging an item “public” doesn’t display on my default dashboard.


I’ve tried changing flags back in the gui, setting the “public” field in the DB to 1, rebuilding the dashboard…

Anyone else have this sort of issue?


What am I expected to see? I get this…

Yep you get part of the page. Some items render, some don’t there should, for example, be an instantaneous solar output as well as bars above the bits you can see for the individual circuits - pool, oven, air cons (there are two) as well as grid ± and the output from the 2 solars.

Sorry, it should look like this

FYI - we are under a bush fire threat here. The reduced solar output it directly related to a fire 16Km to the west of us.

Here are the temp and humidity for the last 24 hours with other graphs that should be public

Have you made the dashboard/widget public as well as the feed?

I’ve never played with this aspect of EmonCMS so can’t really help.

1 Like

Could you do a side by side screenshot showing what is and what is not showing in public vs logged in view?

PS: hope you stay safe with the fires!

Thanks for having a look at this guys. Fire has subsided but won’t be extinguished until we get substantial rain.

Public - not logged in but everything marked “public”

Everything marked public - logged in.