Ethernet gateway not working after upgrade

I’ve been ignoring this issue for quite some time and just getting by with a constant 32amp charger. I upgraded the wifi gateway firmware (esp32-gateway) via the web interface on my OpenEVSE a few months ago and I’ve not been able to connect to it since (wifi or ethernet). I bought my OpenEVSE in October 2022. Here is what my invoice says if it helps you understand what hardware I have.

It was working okay with the firmware it came with before I updated it.

When I finally got round to viewing the serial output today I am getting the following message:

ets Jul 29 2019 12:21:46

rst:0xc (SW_CPU_RESET),boot:0x1a (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
mode:DIO, clock div:2
entry 0x400805e4

OpenEVSE WiFI 4984
Firmware: 4.1.7
Build date: Dec 18 2022 01:57:22
IDF version: v4.4.1-1-gb8050b365e
Free: 265524
[   239][E][esp32-hal-adc.c:180] __analogRead(): Pin 1 is not ADC pin!
Connecting to SSID: home_wifi
Connected, IP:
Guru Meditation Error: Core  1 panic'ed (LoadProhibited). Exception was unhandled.

Core  1 register dump:
PC      : 0x400f2ad6  PS      : 0x00060330  A0      : 0x800f2b1a  A1      : 0x3ffcc2c0  
A2      : 0x3ffd6528  A3      : 0x400f92d4  A4      : 0x00000000  A5      : 0x00000000  
A6      : 0xffffffff  A7      : 0x3ffc58e8  A8      : 0x800f2acf  A9      : 0x3ffcc2b0  
A10     : 0x0000050a  A11     : 0x40942898  A12     : 0x0000000b  A13     : 0x0000050a  
A14     : 0x7ff00000  A15     : 0x7ff42898  SAR     : 0x00000015  EXCCAUSE: 0x0000001c  
EXCVADDR: 0x00000000  LBEG    : 0x400029ac  LEND    : 0x400029cb  LCOUNT  : 0x00000000  

Backtrace:0x400f2ad3:0x3ffcc2c00x400f2b17:0x3ffcc2f0 0x400f8d4a:0x3ffcc320 0x400f8f21:0x3ffcc480 0x400f9408:0x3ffcc500 0x400f9455:0x3ffcc5a0 0x400f2293:0x3ffcc5c0 0x400e7e0d:0x3ffcc5e0 0x400fd89d:0x3ffcc670 0x400e7f6e:0x3ffcc690 0x400e8015:0x3ffcc6b0 0x400e2531:0x3ffcc6d0 0x400e2a95:0x3ffcc720 0x400e23a9:0x3ffcc790 0x400ef8e5:0x3ffcc840 0x400ef954:0x3ffcc990 

ELF file SHA256: 0000000000000000


Mainly double dutch to me. My guess from “Pin 1 is not ADC” is that I uploaded the wrong firmware.

I have had a go at manually uploading v4.2.2 firmware to the board (via the USB port). Hopefully getting the right firmware this time. I’ve tried various connection speeds, firmwares and cables but I still get the same output.

trying to connect
flush start
setting serial port timeouts to 1 ms
setting serial port timeouts to 1000 ms
flush complete
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
read 0, requested 1
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
Finished with exit code -1

Any advice would be greatly appreciated.


Oh dear, very sorry to hear you’re having issues. Which firmware file did you use for the update?

Assuming you have OpenEVSE WiFi V1 module, the correct firmware is: Success

Can you verify your hardware:

Please share a photo.

Mmm non of the WiFi modules have a USB port, are you sure you’ve got a WiFi module and not an Ethernet Gateway?

Ah right. Yes, I have a wifi gateway. I am at work just now so can’t send a picture of kit, but it is one of these. I’ll look carefully when I get back to see which variant it is.

ESP32_WiFi_V4.x/docs/ at master · OpenEVSE/ESP32_WiFi_V4.x · GitHub

Looking back at what I uploaded, it was “openevse_esp32_gateway-e.bin”. I am guessing I probably have an “f” or “g” variant. Pretty sure I was trying those last night…will let you know how I get on.

Got it sorted. Firstly, I installed the wrong firmware. I installed openevse_esp32_gateway-e.bin rather than openevse_esp32_gateway-f.bin

Then when I was trying to upload the correct firmware I was getting a random error as I wasn’t following the instructions at ESP32_WiFi_V4.x/docs/ at 4.1.2 · OpenEVSE/ESP32_WiFi_V4.x · GitHub. More specifically, I was being lazy and using “esptool-gui.exe” that I thought had the same functionality as, but it doesn’t.

Thanks for pointing me in the right direction


Nice work! :+1: