ESP8266 still broadcasting after connecting to local WLAN

Hi team

EmoNTX 3.4 and ESP8266 has successfully connected to my local WLAN and has established a connection to How do I stop it from broadcasting an unencrypted/unauthenticated “EmonESP” SSID?

This might be related to the issue discussed in the “Perhaps someone can help with a esp / arduino question” thread. Maybe @glyn.hudson or @TrystanLea will be able to help.

Looking forward to a solution

On the web config of the EmonESP there should be a button to turn off the AP. Just under the WiFi info, if not there will be shortly as I will be merging that from the OpenEVSE code :wink:

Yes, there should be a button called “Turn off AP” on the emonESP web interface.

Thanks @jeremypoulter! We can all look forward to a big improvement in EmonESP webpage performance when the javascript and async web server changes are merged .

Oh, thanks all! I just tried the “Turn Access Point Off” button and it has now disabled the original EmonESP unencrypted AP. It is still connected to my WLAN which is perfect.

Slightly counter-intuitive, maybe the button could be renamed.


I would agree, the AP is kept running so the UI is updated. Perhaps what should happen is the UI should redirected to the new client IP and turn the AP off on connecting to the network.

There probably should also be a button to turn the AP back on, surely it is of vital importance to someone.