ESP8266 OpenEVSE WiFi V2.9.0 beta: Significant update Solar PV Divert 🎉


connect to your Emonpi and click on the inputs tab on the left, scroll down and you should see a section called openevse, if that is there then you do not need to recreate it. then click on feeds on the left, you should have a section called openevse, if you do then all is good. the only bit you may need to do is modify one of the input processes to output an MQTT feed to publish your “spare” solar power. it should look like the pic attached this is the power1 input (assuming your names are normal) you then need to add this new feed as the “modulator” in the EVSE as per the pic.

Annotation 2020-07-21 103526

OK, I finally got the new software working again. I shall not bore you with the issues but updating the Emonpi was a good idea.

With the car plugged in and surplus PV power available I selected Eco mode and charging started as expected. The PV power increased and the charging current increased. Then the cooker was switched on and the surplus disappeared, charging then stopped. All good so far.

When the cooker switched off charging did not re-start even though the OpenEVse app was showing over 3kW going to the grid. This persisted until I decided to power cycle the EVse unit. When it re-booted it failed to connect to the wifi and was not broadcasting its SSD.

I would dearly like to put back the old software but cannot do that until I can communicate with it again.

I really need some help with this @glyn.hudson

I have uploaded a video here:
Can I simply purchase an ESP32? Would that work?


if you want to revert you need to download the .bin file to your laptop, then go close to the EVSE and on the laptop search for WiFi you should find one broadcasting evsexxx connect to this the password is openevse you can the either set up the connection to your main WiFi or tap the button at the bottom to just connect you can then upload the .bin and re-connect your WiFi . You may have to add in the services again. I have reverted at the moment as am still waiting to get onto “agile” tariff and was getting odd reports saying the car had been charging from even when the car was not connected so will wait a bit end prob update to the esp32 enet version.


1 Like

Thanks John

I assumed the box was not broadcasting its SSD because it did not appear on the LCD. However, when I checked on my phone it was so could then revert to 2.8.0 which is now running. This version has been stable for me for a couple of years.

Can you select below 10A? I am sure mine could do 6A but now a minimum of 10A. Maybe I am going senile?

I learnt a couple of things in this exercise so will post them here in case anyone is interested:

Make sure the Emonpi is running fully up-to-date software.

RTFM. Then RTFM. It’s all in there but it’s a huge manual and difficult to navigate but RTFM.



yes can select all the values between 6A - 25A.
There is lots of info in the manual, but sometimes a small point in the correct direction helps :slight_smile:
I reverted at the moment as until I change tariff I cannot use all the facilities so may get the ethernet version once it is back in stock

That’s odd, I am sure mine was the same as you. Now on service level 2 (240V) V 2.8.0 I can set the Max Current between 10A and 80A.

Service level 1 (110V) goes between 6A and 16A.

There is an intentional delay to stop the charger cycling. This delay can be adjusted in advanced settings.

What communication have you lost since upgrading?

An ESP32 will be drop in replacement and will get future updates. However, the ESP8266 should work fine. Did EcoMode work ok on the ESP8266 previously before updating?

Ahh, excellent. Thank you

The EVse reverts to transmitting the SSID. It did this twice but has never done than in the previous two years.

Yes apart from the fact that when I plugged in the default was manual. Defaulting to Eco will suit me more but I shall wait until things are more stable.

Thank you for replying

This sounds like the EVSE is dropping off the WiFi network. Is there a strong WiFi signal where the unit is installed? This updated should not have changed anything to do with the WiFi. Did the unit successfully reconnect? Or did you have to manually connect?

Yes, this new version will persist Eco mode between charging sessions. I’ve had mostly positive feedback regarding this update, it will be tagged as a stable release next week unless there are any significant issues reported.

The WiFi signal is -28dBm see below. Using version 2.8.0 it has never dropped out in the last year. Now using version 2.9.0 it reverts to transmitting its SSID within minutes which may indicate a loss of WiFi signal but the unit is only 200mm from the hub.

No it does not successfully reconnect I have to go through the connection process again.

I don’t see how this can be classed as a stable release but if there any tests or changes you would like me to try I am happy to help. Otherwise I will continue with version 2.8.0 which definitely is a stable release.

Installed working perfectly! Thanks Glynn!

Great good to hear, thanks for letting us know :+1:

Oh dear, that must be very frustrating. -28dBm should be a strong connection. I can’t see to replicate this issue on any of our test systems running 2.9.0. There are no changes made to the WiFi connection between 2.8.0 to 2.9.0 so this is very strange. Are there any other changes in your installation location which could have effected this? What ESP8266 module are you using?

Has reverting to 2.8.0 solved the WiF issue you were experiancing?

Agreed, it looks very odd but I am happy to wait for some more feedback from other users.

Not that I am aware of. Also, when I reverted to 2.8.0 everything worked fine again.

I don’t know how to tell.

Yes and I am happy to stay with 2.8.0 for now. I can see that Geoffrey is very happy with 2.9.0 so clearly the problem does not apply to all.

Was it a module supplied via the OpenEnergyMonitor store?

Yes, it all came from you guys a couple of years ago:


a quick question when upgrading to this new version are any changes needed on the Emonpi feeds needed? As when I tried the upgrade the system (EVSE) worked great but I had some very spurious results in the ev_energy feed on this caused the mobile app to report that the car had been charged even though it was not connected that day. Would love to go back to this new version but with the odd readings have been staying on 2.8.0 for now.


Hi John,

No changes should be required to Emoncms. The V2.9.0 should report the same data to Emoncms.

Please could you post some screenshots to illustrate the issues you experienced after updating to V2.9.0?


Will try the update again tomorrow as will be doing another charge, will takes some snapshots today of the current feeds.



updated to V2.9.1 this morning and charged up the car and all seems well. Only change I had to make was to the mobile Emoncms app page I have for the car charging was to the Wh or kWh Feed section I had to change to Watt hours elapsed from Kw. Will see if all the charge reports look OK tomorrow :slight_smile:

1 Like