ESP32 firmware problems

Hi I have a issue with the ESP32 module for the OpenEVSE system.

Of some reason maybe a interrupted upload of firmware I now have a ESP32 not working.
The board is now rebooting all the time with the following output on the uart:

flash read err, 1000
ets_main.c 371

I have tried with diffrent versions with out any luck.

I am using the NodeMCU PyFlasher to flash the prebuild image.

But if I try with Arduino and uploading a fresh compiled test software the ESP32 starts up, without any problems.

What is it that I am doing wrong here, can it be that the downloaded image must be uploaded thug the web interface, is so how can I get back on track again.

Best regards

@glyn.hudson is the man to help

Am I really the first one with this problem?

@glyn.hudson @TrystanLea - sorry they are the only 2 who can help.

Hi Peter,

Sorry to hear your having issues with the ESP32 module? Was the ESP32 module your having issues with shipped by OpenEnergyMonitor? I notice you have ordered one but the tracking indicates that is has not yet been delivered.

It sounds like you will need to use esptool to perform a full erase then upload the firmware:

$ erase_flash

See instructions to flash firmware: GitHub - OpenEVSE/ESP32_WiFi_V4.x: OpenEVSE V3 WiFi gateway using ESP32

Hi Glyn

The module was purchased from openevse in the US a few weeks ago, the one there is on the way right now is just a backup.

I was working until I tried to update it.

I have tried to erase the flash as you suggested.

>python.exe erase_flash v2.8

Found 3 serial ports

Serial port COM7


Detecting chip type... ESP32

Chip is ESP32D0WDQ6 (revision 1)

Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None

Crystal is 40MHz

MAC: ac:67:b2:0b:28:8c

Uploading stub...

Running stub...

Stub running...

Erasing flash (this may take a while)...

Chip erase completed successfully in 8.2s

Hard resetting via RTS pin...

Programming again with NodeMCU:

But still rebooting and dumping the same on the uart


flash read err, 1000

ets_main.c 371

Please advice.

Best regards


I’ve tried to format your post to make it a bit clearer.

When posting code or output, can you please put 3 ‘backticks’ (normally found at the top left of the keyboard) on a line of their own before the code, and 3 more backticks on a line of their own after the code.


If it is something like php you can add a language identifier that after the first 3 backticks so ```php

Thanks, I did not know that.

Just to try somthing, where can I finde the bootloader.bin and partitions.bin without compiling everything myself ?

Sorry, I’m not familiar with the ESP32.

Do you know where I can find the bootloader.bin and partitions.bin files ?

Pre-compiled versions of the ESP32 OpenEVSE WiFi V3 firmware can be found on the releases page: Releases · OpenEVSE/ESP32_WiFi_V4.x · GitHub

Hi Glyn
Strange that I did not see the files before.

Now the ESP32 is working again, thanks for support.

Best regards

@oz1paj I don’t understand. How did you resolve your issue? Why you were searching bootloader.bin and partitions.bin files? After you did find them, how did you use them? Thanks in advance.

Hi, please can you explain me how could you resolve your issue? Thanks in advance.

Is there another solution? I am experiencing the same “flash read err, 1000” error. This all started when I tried to update to 4.1.2 via browser. This firmware updated appeared to work fine, but I could only access the wifi module via AP or standalone modes.

I tried to update firmware via browser, and that failed. I later used a programmer to erase_flash before attempting to burn 4.1.2 or 4.1.1. Output showed success, but wifi module never appears to boot. When I checked serial monitor, the chip continues to post “flash read err, 1000”.