Community
OpenEnergyMonitor

Community

ESP 32 beta loss of WiFi connection

Hi anybody trying the esp32 board and beta software for WiFi connection on the EVSE Controler
I have programmed two Vroom ESP32 mode boards and have been trying them for the last week
Using esp32 version 3.0.3 .dev. And the latest evse .eu. These connect to my virgin media WiFi hub
And send information to emonpi .
On power up these are working as expected .
But after several hours they will loose the WiFi connection to my network and not restore it untill power off reboot . I have googled this on the web and found many posts regarding this problem .
I am wondering if it is a problem with just my two boards. Or if it is a problem others on the group are having . As most of the posts I find on google are over a year old .

@glyn.hudson

Hi @Bill_Burgess, I’ve been running a number of ESP32 units with WiFi 3.x firmware for many months now without any WiFi issues. I’ve been testing with the ESP32 huzzah which is a pin compatible replacement, we’ve started selling the ESP32 huzzah pre-loaded for beta testers :

What board are you using? Did you compile the code yourself or upload the pre-compiled .bin from the release page? This pre-compiled .bin is for the Huzzah module and may not work with other modules. See platfromio.ini for other supported modules.

I’m happy to send you a pre-loaded ESP32 module if you would like to test in your WiFi environment. Drop me a PM if your interested.

What is your WiFi environment like? What wifi RSSI readings do you get?

My experience is that it is often Router dependent. I have had exactly the same code connect rock solid to one router and be really flaky with another.

Yes I have had problems in the past with network
Equipment that does not want to play ball and allow
Equipment to connect but must admit I have not had the problem with equipment losing the conection or failing to reconnect . Will try and set up on the bench and try some other network access points I have . See if I can get anything capture with wire shark

hi @glyn.hudson at present i have put the old esp boards back they are reporting rssi -52
they are 5 mt away from wifi router but other side of 9in brick wall .
the esp32 boards as some i brought of ebay


i compiled the code as your instruction on my linux laptop for both of them . i have also tried
uploading the binary file to one of them to see if it was something i was doing when compiling it . but that still drops out … i have sent a picture of the board if you think it may be beter if i compile it again as a diferant board i will need you to tell me how to do that for platform io … as i am not that proficant with it
regards Bill

Out of interest, could I send you one pre-loaded ESP32 Huzzah for you to test on your wifi network? This will reduce the number of variables since the ESP32 has been proven to be reliable on the networks I’ve tested it on. Please PM me your shipping address if you would be happy to test.

hi Glyn not sure if you got the msg i sent to you with my AD
would love to try one of your boards
bill

Hi Bill,

Got your message, we’ll send out a pre-loaded board to you today.

Many thanks

Regards. Bill

I’m seeing occasional loss of connectivity to the ESP32 web page. I typically have both desktop and mobile phone connected. Mostly it works fine, but maybe 2 or 3 times a week it becomes unresponsive, not responding to commands, although the clock time is still showing as ticking. Power off/on of the OpenEVSE gets it back alive again.

Subjectively, it seems to happen mostly soon after a car charge has finished when the OpenEVSE turns off the current - I don’t suppose it could be a supply glitch or induced interference from that operation?

I’m using the ESP32 that Glyn supplied with my OpenEVSE kit. Version 3.0.3dev. My router is a Draytek 2860n.

Isn’t the power switched by a contactor in the EVSE? If so, I wouldn’t dismiss that quite so readily. To check the suppression on the coil circuit ,as well as on the contacts, would be my first step.

intresting point on inductive spikes. on my system i use a 63 amp 240 V ac contactor .
with 240 volt coil using the ac switching portion of the board to control this .
been working fine with the old esp 8266 boards never had any issue i was surprised as i have used the boards for other things and had the wdt timer reseting them but in this aplication they worked perfect .
The new board thet Glyn sent me has been runing since friday night and has failed to allow me to conect one time after about 6 hrs .

To day i have had a major rehash and have now set up on a pi 4 and at present i am rebuilding up emonpi as a clean install .

I have some rc snubbers that i will fit acrose the contactor coil and see if that will improve things . it cant hurt to try .
job for tomorrow .

hi Glyn
Thanks for the board it has been running since friday .
i have had two issues with it in that time now it would seem that it is not crashing if to day is anything to go by . i have also started with a new virgin install of emonpi on Pi 4 .
i have set up with the demand shaper to do timed charge based on argile tariff as that at some point is what i should be on .
I wanted to do a charge when i got home to do some other testing but found i could not get conected to the webpage to start a charge. conection was timing out .
i did a network scan and found the ip adress was reported as only having Ping capabilaty on
net analyzer on my I phone .
i then opend up on laptop emonpi and in the demand shaper ajusted the time to make it turn chargeing on and was surprised when the charger responded and started to charge at a current of 6 amps so we had comunication between emonpi and the esp32 evse over wifi .
but i could not conect to it from my phone using its ip number . or from the laptop .
when i went and actualy looked at the charger the lcd was blank no light .
i powerd off the charger and rebootred it and display returned to normal . and conection was now posable via my phone and laptop .
the other things that had changed was that the max current was now set to 6 amp was 32
the diode check was diabled
the ground monitoring was disabled.

I also notice that on the ECO pv divert that we now get a charge rate indicated of -1A
at times ie grid import/export -5W charge rate -1A

i will try and monitor a bit more closley next time it gives issue anything you would like to know ?
open EVSE firmware 5.1.0.EU from image upload to system via web interface
protocol 4.0.1
open EVSE wifi firmware 3.0.3.dev
flash size 4096k
free ram 236k
regards bill

Thanks Bill, that’s really useful feedback. Your observations indicate that when the module seemed like it had lost WiFi connection it was still actually connected to WiFi and connected to MQTT since the demand shaper uses MQTT to communicate with the charger. It’s only the web server that was not responding.

It’s very frustrating that I’m unable to replicate any of the web server connectivity issues on any of the ESP32 units that I’ve got running at home, in the lab or on a number of test installations. I’ll keep monitoring them carefully.

Update. Well I fitted a Rc snubber on the contactor coil this is 240vac

The snubber is marked as 47n+100R.
On Saturday. After resetting

I have charged once since then .

I still have web access this morning so it may have helped ?

I will keep monitoring it .

Regards. Bill

We may have a fix for the WiFi issue:

See attached for compiled firmware 3.0.4 which contains this fix. The firmware can be updated via the web interface GUI.

firmware.bin (1.2 MB)

Please let me know if it improves the issue.

Thanks for the update i have loaded it to night i will monitor it and see how it behaves
at moment doing some self isolation back to work next week so will be back to charging every day. i will bring up one of my other boards that were giving me regular problems and see if it has improved them . fingers crossed .

bill

1 Like

Thanks, let me know how it goes.

Stay safe out there!

Hi Glyn
I bought the ESP32 from the shop. I had no problems connecting first time around (firmware 3.0.3) but when I turned the charger off from the mains and restarted, the wifi just would not connect. I cleared all history (safari) and then I did connect. I have upgraded to firmware 3.0.4 that took a long time!
I forgot I was on wifi usually try to do that via a wired connection.
Anyway working now will let you know how it goes.
Geoffrey