Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Error running /home/pi/emonpi/service-runner-update.sh

I have recently updated my EmonCMS to 10.5.6 (from 10.1.1) and am trying to get the automatic configuration ‘service-runner’ operational. I’m running Ubuntu 18.04.4 LTS on Azure. I had a few problems that didn’t take long to nut out but this one has me. When I run an update from the admin menu I get the above error. Naturally, this is not running on a Pi. I’ve searched around and can’t find where the above path is configured or can I find a file “service-runner-update.sh”. Can anyone give me a pointer on how to correct this?

The other issue is I can’t add or edit existing users. I’m an admin and have tested that my changing the admin flag in the DB from 1 to 0 and back but no luck. Is there a parameter elsewhere I should update

TIA

/Tony

Hello @Tony_Glynn Have you set the user, following the non-raspbian setup instructions here emoncms/install-service-runner-update.md at master · emoncms/emoncms · GitHub?

Do you see the users listed under Admin > Users?

Hi Trystan,

Yes - sudo systemctl edit service-runner.service? I’ve tried with both a blank “User=” and using a normal account. Its curious that the error

LAST ENTRIES ON THE LOG FILE
Error running [/home/pi/emonpi/service-runner-update.sh emoncms emonpi]Exception occurred: [Errno 2] No such file or directory: '/home/pi/emonpi/service-runner-update.sh': '/home/pi/emonpi/service-runner-update.sh'

Includes “emonpi” as a component to update.

I can see users in admin/users view but only have “view” buttons.

Hello @Tony_Glynn

You need to have the EmonScripts repository installed in /opt/openenergymonitor, emoncms will then detect it’s presence and update using the newer update system.

That is correct, you can add new users by adding:

enable_multi_user = true

in the [interface] section of settings.ini.

This will then show the register option on the login page.

You can then edit the users by logging in to each user individually.

Thanks Trystan,

Users can now be created.

I can’t get the update system working, I’ve copied the EmonScripts repo into /opt/openenergymonitor/EmonScripts but it is still referring to /home/pi. I’ve added a config.ini (in “/install”?) with a single line

emonSD_pi_env=0

but nothing changes. I don’t want to run the init.sh or main.sh as this will probably toast my existing install. I think I can probably live without the update function as I think I have to move my install (Azure credits about to run out) to AWS and the simpler path will be a clean install on the new server.

Other minor issue is I have a virtual feed that used to work but now returns NULL. Is there a module I need to install to support the VF?

Yes that sounds like a good plan. If you install using EmonScripts installation script from the start you will have everything in the right place.

Ok, do you know the feed engine of the source feed/s that it’s using? perhaps if you could share a screenshot of the processing window for the virtual feed I can try and replicate it here.

Thanks for the prompt reply Trystan. I have the new AWS server up already. Everything works. I can now see the component update dialog. Previous I just had the CORE component. The install script runs swiftly and without error.

Must be my dodgy build from 3 years ago.

The source feeds for virtual feed are PHPFINA