EmonTx v3 & WiFi

I purchased EmonTx V3, ACAC Us, and ESP8266 WiFi adaptor. EmonTx pcb arrived correctly configured with jumper JP2 removed and ESP8266 correctly configured with the Tx pin clipped and the Rx pin reconfigured correctly. I am currently using one clip on current sensor. I’m powering EmonTx from a 2.5A USB power source and a 12" USB cable. EmonTx with the WiFi adaptor is sitting within inches of both my laptop and my Android phone. When I power the unit up I get the red power LED beside the USB socket and red & blue LEDs on the WiFi module. I’ve seen “espwifi6771” twice briefly when I power up the unit - then the wifi signal from Emon/ESP dissappears. Any clues?

Welcome, Bruce, to to OEM forum.

Does the red LED on the ESP8266 remain on continuously, and does the red LED on the emonTx (between the a.c. and the USB sockets) and the blue LED on the ESP8266 flash in unison every 10 s or so?

The only suggestion that springs to mind is, can you check the USB cable? If it has too much resistance, it’s possible that the voltage is falling too far to operate the emonTx and ESP8266 together. You could ‘prove’ this by disconnecting the ESP; the emonTx will function on its own, but of course there’s no WiFi. If you do get the red flashes from the emonTx’s LED, then I think that’s a reasonable indication that you’ve got a problem with either the cable, your 5 V PSU or both. My money would be on the cable - our Shop had to change to a USB cable with more copper in it because of similar problems.

I live in the UK and have set up and emontx v3 and the WiFi module supplied by the open energy monitor shop.

When I first set this up on my test bench I had an intermittent problem whereby on power up the red led wouldn’t always stay on for 10 seconds ad it should. I found I had an intermittent usb power connection. In my case changing the mini usb cable fixed it.

I run mine in conjunction with Homeassistant which pings the emontx (or probably the ESP8266) every 30 seconds and I get a notification if it the ping is unsuccessful which thankfully hasn’t happened since changing the USB cable.

I received replies from both of you. I’m replying to 1 email with both of u on it. The replies were quite similar.

I’ve used multiple cables and USB power modules. Power modules are capable of at least 2.4A. I measured the following voltages:

With ESP8226 installed
At usb power pins on EMON Tx: 5.03 VDC
At ESP8226 5 pin header V+ & GND: 5.01 VDC

Without ESP8266 installed
At usp power pins on EMON Tx: 5.13 VDC
At ESP8266 5 pin header V+ & GND: 5.13 VDC

I’m attaching 2 videos, one showing the behavior of ESP8226 LEDs on power up, one showing the power LED behavior on EMON TX power up.

(Attachment ESP8266 LEDs on PowerUp 16jan22.mp4 is missing)

(Attachment EMON Tx V3 LEDs on PowerUp 16jan22.mp4 is missing)

Lets try this one at a time & smaller

ESP8266 LEDs on PowerUp 16jan22 1.mp4 (8.71 MB)

EMON Tx V3 LEDs on PowerUp 16jan22 1.mp4 (8.1 MB)

It would appear that both the emonTx and the ESP8266 are operating as expected.

Where are you looking for that?

How far did you get through this? GitHub - openenergymonitor/EmonESP: ESP8266 WIFI serial to emoncms link

Thanku very very much for getting back to me.

It popped up in my WiFi window. Fourmile Manor and Fourmile Manor 2 are my normal wifi networks.
I’d open Chrome and would pop up in my address bar. I’d get a message something like
“this may take up to 10 seconds” but the browser would just hang there.

What’s puzzling me is it looked as if the emonTx and ESP were working normally - from your video. I.E, it has gone past the AP stage and has connected to and got an IP address from the router. If you look at the network devices on your router, do you in fact have the ESP using an IP address that the router has given it, and if so, is it there when you direct the browser to it?

I’m not an expert on the ESP, so I might well be misinterpreting the indications from it. I think it needs someone who knows the ESP better to help you.

It doesn’t seem that it generally makes it that far. This snip is what’s left over from the last of 2 times my laptop did see the ESP. Any clue how I’d find someone who knows ESP better? I’m a hardware type and have less than zero depth when it comes to networking.

This might well be @glyn.hudson

Thanku very much Robert. Are u an employee of Open Energy?

Definitely not - see my user profile. I just do ‘moderator’ duty and contribute software (and occasionally help out with hardware design) on a purely voluntary basis, as do all but a very select few.

Hi Glyn, I’ve been trying to run down a problem with ESP8266. I’ve had a fairly in depth email conversation with Robert Wall in the EMON Community and he finally suggested I get in touch with you.

I’ve just purchased EMON Tx & ESP8266. Based on videos of EMON Tx & ESP LEDs at power up (I’ve attached these videos), Robert Wall said they appear to be functioning properly but I haven’t been able to establish communication with the ESP.

I’ve followed Setup Procedures and “espwifi6771” has briefly appeared twice in my Available Networks list. Both of those times192.168.4.1 appeared in my Chrome browser and when I navigated to I’d get a message something like “…may take 10 seconds” but nothing happens.

I’ve verified the units arrived configured correctly with JP2 open on EMON Tx and the TX pin on ESP configured correctly.

EMON Tx / ESP are sitting next to my laptop and Android - I don’t get “espwifi6771” in my Android’s Available Networks list either.

I’ve used multiple USB cables and 2.4A USB power modules as inadequate power has been a typical user problem. And I’ve measured the following voltages:

With ESP8226 installed

At usb power pins on EMON Tx: 5.03 VDC

At ESP8226 5 pin header V+ & GND: 5.01 VDC

Without ESP8266 installed

At usp power pins on EMON Tx: 5.13 VDC

At ESP8266 5 pin header V+ & GND: 5.13 VDC

Can you please help?

Bruce Schwartz

[Duplicates of videos deleted. Moderator (RW) ]