Community
OpenEnergyMonitor

Community

emonTx v3 & ESP8266 Huzzah WiFi module can't connect to emonESP


(chris_cronin) #1

Need some help setting up emonTx/Esp8266.
I uploaded emonTxFirmware to emonTx & get the expexted serial output in the form P1:00,P2:00,P3:00 (all zeroes as no CT’s connected yet as working on bench).
I then uploaded the ‘src’ sketch fron within emonESP to the ESP8266 Huzzah & the serial output was:
EmonESP 12792858
Firmware: BUILD_TAG
Starting APScan: 15 networks found
AP IP Address: 192.168.4.1
Server started
So that seems OK, however, when I try to connect to EmonESP 12792858 sometimes it connects to the internet showing (connected, open) & sometimes showing (no internet, open). Windows 10 connects to the internet normally using the built in WiFi.
When EmonESP 12792858 does connect to the internet that’s as far as it goes, I don’t get the emonESP screen shown in the installation instructions prompting for an API key. I’ve tried entering both 192.168.4.1 & 192.168.4.100 into a browser but get nothing other than page not found or constant buffering.
Any suggestions?


(Paul) #2

Did you upload “spiffs” in addition to the src.ino?

via Arduino IDE

https://github.com/openenergymonitor/EmonESP#2-install-esp-spiffs-filesystem-file-uploader-plug-in

via PlatformIO

https://github.com/openenergymonitor/EmonESP#b-upload-data-folder-to-the-file-system-html-css-etc-spiffs


(chris_cronin) #3

No, I didn’t upload ‘spiffs’.

Followed the ‘via Arduino IDE’ link you suggested & the first went OK but the 2nd part about ‘Tools > ESP8266 sketch data upload’ failed with an error about ‘no room for spiffs’ (or something like that) so I set

Flash size: 4M(1M SPIFFS) & spiffs appeared to install (well it got to 100%)

Still the same problem with connecting to emonESP. I’m connected to the internet via the ‘hotspot’ (emonESP_12792858) but I don’t know what to do next. If I try to connect to emoncms I get my old emon Tx v2 feeds page which doesn’t update any more since the failure of my emontx.emonbase/emonGLCD setup.
Any ideas where i’m going wrong?


(Paul) #4

Not on the info you’ve given us

I’m not an emonESP expert so hopefully someone else will jump in on that issue.

I’ve no idea about this bit, is this related to the emonESP issues? What failed? surely not all 3 components? How does the emonTx v2 connect to emoncms? Is the stalled feeds page on that emonBase or somewhere else?


(chris_cronin) #5

I don’t which of the 3 components of the old v2 setup failed as all LED’s flashed as normal except for the emonbase (green LED ON & no intermittent flash from red LED).
I swapped out the RFM12 BSP chips on the emontx & emonbase base still no feed update to emoncms & as they’re 7 years old I decided to upgrade to the latest emonTx v3 with ESP8266


(Paul) #6

Ok, so aside from being the reason you have bought the emonesp and emonTx v3 it is unrelated.

If you want to get this gear up and running again, we can give it a go, I would not be concerned about its age, regarding physical condition, but I have no doubt some sw updates or possibly a new SD card and image might breath new life into it. But you should start another thread for that and we would need more info and for you to go through some debugging steps, so it might be better to focus on one part (the new bits or the old bits) before tackling the other.

Can we assume then, that the emonTx v2 page that is not updating is at emoncms.org then? Or are you still running the emonbase as a server?


(chris_cronin) #7

Yes the emonTx v2 page that is not updating is at emoncms.org but for now I wish to concentrate on setting up the new emonTx v3 with emonESP. Maybe I’ll come back to the old emonTx v2 in the future


(Robert Wall) #10

As the “old” equipment is 7 years old, is your “emonBase” a NanodeRF?


(chris_cronin) #11

Yes, all 3 bought at the same time.

I’ve gone back over the uploading of src & spiffs. The 1st problem with uploading src was when the upload completed the compiler reported there were no header files (.h) in the library emonESP-master (they were all in the src folder). I copied all .h files to the emonESP-master folder. Uploading src again & this error was not repeated as before.
The upload instructions say: Select Tools > Board > Generic ESP8266 Module but make no mention of Flash size etc. If using an ESP8266 Huzzah should this board be chosen from tools>boards? If so, again what Flash size etc should be used for uploading ‘src’? I used 1M (no SPIFFS)
Similarly, when performing ESP8266 sketch data upload, what settings for the board should be chosen. I used 4M(3M SPIFFS) because using less SPIFFS caused an ‘out of memory’ error.
Finally, checking the serial output of the ESP8266 Huzzah before fitting to emonTx outputted:
Scan: 13 networks found
AP IP Address: 192.168.4.1
Server started
Choosing emonESP_12792858 from my list of available WiFi connections it reported: ‘Connected, open’ but nothing else. I tried http://192.168.4.1 but nothing connected. My browser gave a message: home.html not found, have you flashed the SPIFFS?
I’m not a coder so please keep any advice simple


(ian) #12

Hi Chris

Are you using Arduino?

You tale of woe sounds similar to mine. I was tearing my hair out when I first tried to use emonESP. Then I changed to Platform.IO. It did take quite an effort to install Platform.IO but it has been well worth it. From then on it was like magic. One thing I did discover is that the ESP can store old information that does not get overwritten when you upload src and spiffs. It may pay to erase the ESP before doing anything else.

Also I use Visual Studio Code as the IDE and that has also been a great help to me personally.

Ian


(chris_cronin) #13

Hi Ian
Retried using a new ESP8266 but still the same connection issue.
I had a quick look at PlatformIO but it looks a bit daunting but that may be the route to take unless anyone else can help with this problem


(ian) #14

Chris, are you using Windows or linux to upload to ESP?

Did you get the same message in the browser when you tried the new ESP?


(chris_cronin) #15

I use Windows 10 to upload to the ESP’s

After carrying out a flash erase of both my ESP8266 Huzza’s & retrying the installation of firmware & SPIFFS with exactly the same result as before ie erratic internet connection. When there was a connection there was no emonESP page to login to, just the message: ‘home.html not found, have you flashed the SPIFFS?’.
I’ve decided to return the emonTx for a full refund.
Life’s too short to waste any more time on this ‘kit’.
Thanks to those who offered help