emonTX v3 AC Power supply failure

Installed 2014 working fine for the last 6 years then the 230V/9V AC plug pack went open circuit on the primary. I scavenged a 9V DC plug pack and bypassed the rectifier to get back up and running, but I need to alter the Vcal value as I’m fairly certain the power company is not delivering 275V AC :slight_smile: Actual voltage is 237V according to my Solar PV inverter.
Problem, its been 5 years since I worked with Arduino so I refreshed the IDE and played around with blink.ino on an Arduino Pro Mini until I was satisfied my UART etc was working fine. I can see the boot sequence in Serial Monitor but I cannot get into the Configuration menu with +++. I have tried various combinations of serial settings and looping TX to RX sees characters mirrored, so the UART seems fine. Here is the boot text, what do I have to do to get at that Vcal?

emonTx V3 Discrete Sampling V1.3
Performing power-on tests.....please wait 10s
CT 1 Calibration: 90.90
CT 2 Calibration: 90.90
CT 3 Calibration: 90.90
CT 4 Calibration: 16.60
RMS Voltage on AC-AC Adapter input is: ~203V
AC-AC adapter detected - Real Power measurements enabled
assuming powering from AC-AC adapter (jumper closed)
Vcal: 371.80
Phase Shift: 1.70
NO CT's detected, sampling from CT1 by default
Detected 1 DS18B20..using this for temperature reading
RFM12B Initiated: 
Node: 10 Freq: 433Mhz Network: 210

[Edit Mod] added 3x backticks before and after to format code.

Welcome back, Kevin.

Sorry I’ve missed you - I’m in the UK.

Before you do anything, check which emonTx V3 you have, because the V3.4 was introduced around 2014-2105, and you might have a V3.2. And the V3.2 sketch and the V3.4 sketch are not compatible due to the V3.2 using the RFµ328 module rather than having the '328P processor directly on the main PCB. If you do have V3.2 hardware, you must use the old V3.2 sketch.

If you have the programmer and the Arduino IDE, need to download the sketch from Github and edit the voltage calibration in the sketch, then reload it, because the V3.2 software never had the ‘on-line’ calibration in it, and I don’t think V1.3 did either, it seems to have been introduced with V2.6. If it doesn’t say

POST.....wait 10s
'+++' then [Enter] for config mode

on the serial monitor, then it doesn’t.

If you do have the V3.4.x hardware, you can download the latest Discrete Monitoring sketch and then you’ll have the on-line calibration available, which is easier than repetitively compiling and loading the sketch. :smiley:

From your numbers, Vcal wants to be 371.8 × 237 ÷ 275. You may well find that the PHASECAL also needs to be adjusted - if you’re inclined to do a full calibration, the instructions are in Learn→Electricity Monitoring→Current & Voltage→1. Calibration Procedure→Calibration Procedure

If you do see '+++' then [Enter] for config mode, check that you’ve got Line Endings set to “Both NL & CR”.

Robert, thankyou for the version info and the welcome. I can confirm its the V3.2 hardware with the separate RFµ328 module, the board has V3.2.1 Feb 2014 printed on it. Therefore +++ was never going to work. What puzzles me is I do not have a copy of the V3.2 sketch on my PC and yet I must have had it to change Vcal way back in 2014. Is there no other way to adjust Vcal other than recompiling and loading the V3.2 sketch? Its a lesson for the future, always take notes of what you modified and how. I was reluctant to upload a new sketch in case it changes the inputs and feeds to EMONCMS, but it looks to be unavoidable. I spent a fruitless hour on Github navigating in circles trying to find a copy of emonTX V3 Discrete Sampling V1.3.

I can offer these, all with unknown version numbers:

one dated 23 Feb 2014,
one called “Test.ino”, dated 17 March 2013
one called “emonTxV3_RealPower_Voltage.ino” and one “emonTxV3_RFM12B_DiscreteSampling.ino”, both dated 28 Jan 2014

Your best bet will be an up-to-date continuous monitoring version I did just to prove it would work, which does incorporate the ‘on-line’ calibration. If you’d like that, give me all the details you have that are variable: NodeID, RF frequency, number of temperature sensors, whether you use pulse counting, but most importantly, exactly what it’s sending to emonCMS, and I can customise that for you. You can read those off the inputs page, or emonhub.conf if it’s your personal emoncms running locally.

I know the feeling. You’d do better in a rabbit warren, blindfolded.

1 Like

Back in the rabbit warren, I eventually found emonTxV3 v2.0 which compiled OK once I sorted the relevant libraries.
Your offer of the latest continuous monitoring version is attractive, here is the info you asked for:
1 CT1 Solar
2 CT2 Mains
4 CT4 EV
5 Mains Voltage
6 Temperature
RFM12B Node: 10 Freq: 433Mhz Network: 210
Single DS18B20 attached
Vcal: 320.4
Phase shift: 1.70
CT1-CT3 calibration = 90.90, CT4 calibration = 16.60
No pulse counting

with grateful thanks
Kevin - locked down in NZ

How many temperature sensors does it actually send to emonCMS - I’m guessing it’s only 1 as that’s what emonTx_CT123_Voltage_Temp.ino does.

I just reconnected the emonTx running v2.0 which has provision for up to 7 temp sensors and sure enough I now have 6 additional inputs on emonCMS. The single DS18B20 I have connected is reporting correctly on input 6, inputs 7-12 are all reporting 0. I will try an connecting additional sensor. The existing sensor is measuring the temp of the heatsink on a PV Router which is diverting ~1.25kW at present, heat sink at 29C, all is well. By the way your Vcal calculation was spot on, I am within 0.5V of what my multimeter states. Happy chappy.

How many temperature sensors would you like provision for?

2 will be plenty

Try this. I haven’t exhaustively tested this version, but the one I mentioned ran with the modified JeeLib for about ½ million messages, so I think that side is OK.

The CM library has provision to define the order of temperature sensors, so if you do that (line 70… - you’ll need to use the calibration itself to get the serial number of each, then copy those by hand into the sketch), you can ensure you retain your existing as T1 in emonCMS.

emonTxV3CM_rfm_EEPROM.zip (89.2 KB)

Robert that’s very comprehensive, thank you. I think I will set aside some time for a full recalibrate as you suggest, not today as the sun is shining and the garden needs attention. (apparently) With thanks, Kevin.

1 Like

It might be different now, but my experience of running 8 temp sensors off the TX was it slowed it down. I moved them all onto a WEMOS d1 mini and Tasmota and they sit perfectly happy :grinning:.

It would - getting the serial data takes a long time, if you use the library. emonLibCM doesn’t - it tells the sensors to go ahead and measure, then instead of waiting while they do that, it carries on and comes back when they should have completed the task and reads the values. But it still takes time to poll each one in turn even though it happens while the ADC is busy measuring samples.

1 Like