EmonTx Shield zero readings

Hi everyone,
just tried to upload the latest firmware for emontx shield (GitHub - openenergymonitor/emontx-3phase: emonTx 'approximate' 3-phase firmware) and although it seems to be working i get zero readings for ct1 ct2 ct3 and Vrms.
With the previous firmware (emonTxFirmware/emonTxV3_4_3Phase_Voltage.ino at master · openenergymonitor/emonTxFirmware · GitHub) i got readings from cts and voltage correct.
What am i mising?
Thank you in advance

Have you read and set up the options according to the user guide (originally part of the zip download)?

Yes everything seems correct as per the pdf user guide.

I don’t have an Arduino that I can test it on, only emonTx’s. So I can’t offer specific help for the Shield settings.

Where are you reading the values?
Are you seeing zero values, or no values?

Hi thx for the reply. I get zero values if that helps.

Is this what you are seeing every 10 s:
0.00 0.000 0.000 0.000 0.000 0.00 0.00 0.00 0.00 0.000 0.0000 0.0000 0.0000 0.0000 302.00 Pulses=0 PLL is locked

The only reason that I can think of, is your input pin mappings must be very wrong, or you’ve somehow got zeros for your calibration constants.
Have you tried wiping the EEPROM to reset to the sketch default values?
(Page 8: On-line calibration & configuration of RF Module)

I can’t think of anything else that would give zeros for all the values.

0.00 0.000 0.000 0.000 0.000 0.00 0.00 0.00 0.00 50.179 0.0000 0.0000 0.0000 0.0000 302.00 PLL is locked
0.00 0.000 0.000 0.000 0.000 0.00 0.00 0.00 0.00 50.191 0.0000 0.0000 0.0000 0.0000 302.00 PLL is unlocked
tha is the serial outpout.
I will try what you are suggesting and i’ ll let you know.

The reset did the trick!!! Thank you once more!!!

The mystery there is, how did your EEPROM get set to values of 0x00? The default from new, or what it should be erased to, is 0xFF. On start-up, the EEPROM is read and, if the first byte is not 0xFF, the sketch assumes it’s a valid configuration and uses it. So at some point in time, your EEPROM must have had zeros written to at least the bottom 39 bytes.

When I decided to use the EEPROM to hold the calibration, I followed the system already in use for the RF config. But that doesn’t include a “signature”, so a sketch can’t tell if the EEPROM data is it’s own or something left behind. Your problem was ultimately a consequence of that.