emonTX Shield not working

I powered up my emonTX Shield with out any devices connected
(no current). I was able to logon and connect to my network!

A device was added to my network (emonesp).

Now I can no longer see the hotspot and the emonesp device is not live!!

The LED on the emonTX shield is not lit!


HI, If you have connected an emonesp to the same power supply as the shield you my have overloaded it,as the current drawn by the emonesp i believe can peak as much as 435mA @ 3.3 volts. Check your power supply is still working. Do not connect 5 volts directly to the 3 volt pin on the esp, it won’t like it!

I have the emon 9v AC power supply and the Arduino powered with a USB FTDI 3 volt cable!

The Huzzah with a 5 wire FTDI Female Header the emonTX Shield comes with FTDI 5 pin male.

There is no “official” warning/statement/instruction saying the Huzzah cannot be plugged into the Shield FTDI.

What about the LED not lighting?


Do you mean 5v? The Arduino and emonTxShield are supposed to be running at 5v and the Huzzah, although running at 3.3v it has an onboard 3.3v regulator and is powered via the 5v pin of the FTDI headers.

It is fine to plug the Huzzah into the FTDI header on any emonTx (incl shield), it is meant to be 5v powered.

If your FTDI USB to serial adapter has a 3.3v/5v switch or jumper, try the 5v setting, that should work.

But note some Arduino+shield users have experienced some “oddness” when using 5v to power an Arduino Uno. I think you should be fine using 5v via the header or USB, but if you use the Arduino’s DC input and on-board 5v reg I think it needs to be >7v to work properly. There were a couple of threads about it and IIRC @dBC posted some details on this somewhere on the forum.

Spot on.

The recommended range is from 7 to 12VDC. It is spec’d at greater than 12V, but the
onboard regulator gets quite hot with an input greater than 12V.

Ref: Power Jack & Supply | Ladyada's Learn Arduino - Lesson #0 | Adafruit Learning System

Ok let’s simplify this.

First the emonesp HUZZAH.

I am powering the Huzzah from a USB FTDI 3 volt cable, I am not seeing the Hotspot or my network device.

Same thing with a 3 volt DC power supply still not seeing Hotspot or network device!

Where do I download the emonesp code?


Have you split the unit down and tested the Arduino, then the Arduino+the shield? The 9 volt ac power unit is only to provide a reference voltage and does not power anything.

Yes the Arduino powers from USB.

There is no Power input on the Shield.

By esp you mean the Huzzah correct? Even powering that separately
I do not see the Hotspot or network device!


Do the leds flash on the Huzzah flash once when you power on?

But have you at least tried it with a 5v supply, even if only to prove it isn’t a power supply issue?

Most if not all emonESP (Huzzah) users here will have powered from 5v, I can’t recall anyone else trying to run a Huzzah from 3v. I’m not saying it’s not possible, but it’s certainly not common enough to assume it will definitely always work. It is at the very least an edge case.

From the Huzzah webpages

“The ESP8266 requires 3.3V power voltage and peaks at 500mA or so of current for small periods of time. You’ll want to assume the ESP8266 can draw up to 250mA so budget accordingly. To make it easier to power, we put a high-current-capable 3.3V voltage regulator on the board. It can take 3.4-6V in but you should stick to 4-6V since the ESP8288 has high current usage when WiFi is on.”

So unless you have a solid 3.4v that can provide enough current without a brownout it might not work.

Why do you need to power the Huzzah at 3v? When you power the Arduino and shield correctly it will output 5v at the FTDI connector you are connecting the Huzzah to, so whether it can run at 3v or not should be irrelevant unless you are planning to deviate from how these 3 bits are intended to be powered, at 5v.

Paul I believe I started out saying I had plugged the Huzzah FTDI to the Shield FTDI therefore I was using 5 volts to the Huzzah.

I had not seen that “we put a high current capable 3.3V regulator on the board” so I was trying 3 volts to make sure I did not fry the Huzzah.

Yes the LEDs light at power up and reset!! They will occasionally light while running.

Where do I download esmonesp for the Huzzah in case I garbled the code?


1 Like
1 Like

You did and in the same post you said it had worked briefly but now it didn’t. Since then you have only mentioned 3v.

possibly, possibly not. As both I and Bill have pointed out, the 5v rail may not be 5v, depending on exactly how it’s powered. You haven’t told us how you are powering the Arduino yet.

Did you by any chance change power supply methods between it working and it not working?

The decision to test the boards separately was a good one, but you should use 5v for the Huzzah rather than 3v otherwise the tests are pointless. If by powering the Huzzah via a known good 5v supply, it works then you can look at the Arduino+shield power a bit closer, it it doesn’t work at 5v then look at reinstalling the firmware. You will only be able to install new fw if you have a solid 5v power supply anyway.

That sounds promising, unlikely you have fried anything.

It could well turn out that something has gone wrong with the settings or firmware, but we are just suggesting you check there is gas in the tank before stripping the engine down (or a more fitting analogy, check there enough juice in the battery). A larger portion of hardware faults are power supply related. So far you have tested the Huzzah with a underrated 3v supply, via an Arduino that is itself known to have power issues unless powered correctly and via a FTDI header that may be limited to around 500mA, (possibly set to 3v). None of these are good enough tests to prove the Huzzah isn’t being under-powered.

Simply power the Huzzah up with 5v dc. Connect this between GND and V+,then measure voltage between the GND and 3v point on the Huzzah board.You should see 3.4v approx. I think this will prove enough power is being provided to the unit.

That proves enough voltage is being supplied to the device,
but doesn’t give any indication that enough current is available.

Lack of sufficient current often presents itself with the symptoms Ralph is seeing.

As Bill says, it isn’t conclusive. If there wasn’t 3.3v at that pin it might prove there wasn’t enough voltage/power, but seeing 3.3v is not a positive confirmation of a good supply, even if the voltage appears solid with a DMM, it could be sagging momentarily when attempting to transmit.

P.S. Did you say 3.4v from experience? The tech spec says 3.3v but I’ve never tested one.

“There’s also a 3.3V output from the regulator available on the 3V pin”

I stand corrected ,just measured a working huzzah with a DMM supply 4.94v 3.27v GRN 3v point.

1 Like

Wow!!! Thanks everyone for your help.

It will take a couple of days before I can try powering the Huzzah with 5 volt power supply and re-installing emonesp.

I really appreciate the help.