EmonTx prog_uint8 is deprecated

Hi everybody!
I have an emonTx Shield and emonBase, both with RFM69.
I want to measure current and real power with CT sensors and transmit data via wireless using RFM69 to emonBase

When I use emonTx shield firmware examples from github

#define RF69_COMPAT 1 // set to 1 to use RFM69CW 
#include <JeeLib.h>   // make sure V12 (latest) is used if using RFM69CW
#include "EmonLib.h"
EnergyMonitor ct1,ct2,ct3, ct4; 

At this point if I set to 0, the sketch run well and send data by serial monitor, everything is fine, but I’m not sending data via wireless

If I want to send data with my RF69 I set to 1, but I always get the same error, and it doesn’t send any data by serial monitor, only setup configurations “emonTX Shield CT123 example, OpenEnergyMonitor.org” etc, but no data.
For any reason it gets stuck.

C:\Users\XXXX\Documents\Arduino\libraries\jeelib-master\RF69.cpp:108:38: warning: 'prog_uint8_t' is deprecated [-Wdeprecated-declarations]

 static void initRadio (ROM_UINT8*init) {


I have all library installed, I’m using Arduino IDE 1.8.5 and windows 10, but I also tried with Visual Studio IDE, with windows 7, downgrading the Arduino IDE to 1.0.6 and 1.5.2 and I always get the same error

I appreciate any help, thanks

I suggest using an OLDER version of the JEELIB RFM library rather than the latest one - pick one from the same time range as the examples you are using - probably 2 years old.

That is only a warning, it does not stop your sketch from compiling and working correctly.

If your sketch sticks, then you have a second problem.

You wrote later that you have an emonTx Shield. The emonTx and emonTx Shield need different sketches. You must have the right one.

If you really do have the emonTx Arduino Shield, did you check the jumper settings according to the Build Guide?

Hi Stuart!

Where can I find an older version?
This is the only one that I found https://github.com/jcw/jeelib
and this does not work

or where I can find other example to send data with RF69?
I have searched a lot and I didn’t find anything useful

I have an emonTx shield, sorry my mistake
I’ll check the jumper tomorrow but I think is fine

The sketch you link to is the correct one. The sketch sticking usually means the RFM69CW is not responding to the initialise command. And that is usually because of a bad connection to the radio module itself. The jumper settings could be the bad connection you are looking for.

Do not forget your antenna. It is important. Without it, you must not operate the radio at or near full power, otherwise the output stage might be damaged.

1 Like

I checked the connection and made a better soldering, I think it’s fine, it’s like this image https://wiki.openenergymonitor.org/index.php/File:EmonTx_Shield_top2D.png

But it gets stuck anyway
I dont’ know what happen, maybe my RF69 is defective?

Where did you source the rfm69cw?

I bought in the official shop


Hi Guillermo,

Looks like you could have a faulty RF module. Could you email us at the shop with your order number? We can work out together the best way to resolve this.

1 Like

I checked one last time this morning soldering and jumpers and I don’t know why it works, it’s sending data without any error

I think it was a bad connection… Occam’s razor

Anyways if RF module fails in nexts days I’'ll send an email

Thanks everybody for your help!