EmonTx not updating emonPi

Dear Glyn,

yes I fitted acc. photo.
yes the minicom runing, but don’t show received packet
Please take consideration that I just putted the virgin latest img file, no update is done, no any other command entered just now the minicom.

Dear Glyn, Paul,

In the meantime I installed into a separated SD card a RASPBIAN JESSIE WITH PIXEL.
I disabled the serial port logging in into the kernel in raspi-config , than I checked the
/boot/cmdline.txt as well.

Than I restarded the system, and start the minicom.
I didn’t see any serial communication on the RFMPI69.
Then I switched off and removed the RFMpi69 then I closed shortly the RX - TX pins on Raspi.
Than switch the system back, and no echo received in minicom.

Now I’m on that point that my RX TX line damaged / killed by RFMPI69.

The instresting thing is that nothing was connected to the port just the RFMPI69 when last time 2 weeks ago worked the whole system perfectly. Then I didn’t remove the RFMPI69 from raspberry. I just shut down the system, and I did modifycation only on EmonTX Arduino files (calibration was done)

Please confirm if your statment is the same that the RX TX line dead on my raspi .
Further question If I by a new raspberry, what is the guarantee, that it won’t be killed by the RFMpi69 board again ?

Thanks for your feedback in advance.

Yes, it sounds like this is the correct diagnosis: The Rx / Tx line on your Pi has somehow faulty. We have not heard of the RFM69Pi causing this issue before. However on this occasion since you have had so much trouble we will send you a replacement RaspberrPi. Please let me know if the serial work when the replacement arrives.

Dear Glyn ,

I can’t find words for your kindly support, and great problem solving.
Thank you in advance the replacement Rasp. I’m 100 % sure that it will work, because we exclude every other failure.

Dear Glyn,

thank you very much, the Raspi 3 arrived on last week.
I didn’t have time to try it till now.
Do I need to make a complete new installation on the sd card, or I can insert it to PI3 the already installed SD card ?

Thank you advance for your feedback.

It should be fine to use existing sd card. If you still having issues then maybe try starting with a fresh sd card image

Dear Glyn,

I have realy good news.
I tried and the raspberry PI 3 what you had send, works perfect.
It receive the RX packets and send it to emoncms.org as well, now it works like mine before the RX Tx line stopped working .
Now 100% percent sure that my previous raspi board RX TX line killed before. I hope that this board will “survive”

Thank you again for your great support, and generosity guys.