emonTx Arduino Shield strange reading

everthing is built. the 9 volts is plugged in. i have the ct sensor connected to one wire on my 120 volt space heater, the black one not the green or white one. i commented out alot of the code so that it would read just one ct instead of all four. when the heater is off it gives a reading of zero for real power (thats good). when i turn the heater on it gives a reading of around 0.25 (not so good). i feel like theirs something i need to change in the code but i don’t see it. heres the code i’m using:

#include “EmonLib.h”

EnergyMonitor ct1;
const int LEDpin = 9;
void setup()
{
Serial.begin(9600);
Serial.println(“emonTX Shield CT123 Voltage Serial Only example”);
Serial.println(“OpenEnergyMonitor.org”);

// Calibration factor = CT ratio / burden resistance = (100A / 0.05A) / 33 Ohms = 60.606
ct1.current(1, 60.606);
// (ADC input, calibration, phase_shift)
ct1.voltage(0, 300.6, 1.7);

// Setup indicator LED
pinMode(LEDpin, OUTPUT);
digitalWrite(LEDpin, HIGH);
}

void loop()
{
// Calculate all. No.of crossings, time-out
ct1.calcVI(20,2000);
// Print power
Serial.print(ct1.realPower);
Serial.print(" ");
Serial.println();
// Available properties: ct1.realPower, ct1.apparentPower, ct1.powerFactor, ct1.Irms and ct1.Vrms

delay(5000);
}

found this line in another sketch.
ct1.voltage(0, 130, 1.7);
should be 130 instead of 300.6.
still no joy, i’m now getting reading of around 0.13, its bouncing all over from 0.10 to 0.24.

What CT sensor exactly?

I also suggest you print out the values of ct1.Irms and ct1.Vrms as well.

  1. Can you please format your code to make it readily readable, as we mods are now discouraged from editing posts. Please put three backticks only on a line above and below the code.
  2. You’re in the USA? So the black wire is the line conductor, the white is the neutral? As the heater is only connected to one leg, either should read the correct current.
  3. What voltage are you measuring? You don’t mention an a.c. adapter. Without a voltage, current × zero = zero - hence no power. If you don’t have the a.c. adapter, then you should use ct1.Irms * 120 to give a nominal apparent power.

vrms = 0.05
irms = 8.30
ct is sct013 100a 50ma
9 volt power supply

sorry 9 volt ac adapter, not power supply.

tested 9 volt ac adapter with volt meter, showing 11 volts

You’re not reading, or it’s not seeing, the a.c supply. Vrms should be the 120 V of one leg of your supply. If you are using the a.c adapter from our shop, the 130 calibration constant is the correct nominal value. (300 is for our adapter and 240 V mains.)
The current is clearly right for about 1 kW.

Do you have a multimeter to check the voltage that’s actually arriving from the a.c adapter? It should be around 12 V.

Hopefully a stupid question - you have put the sockets on the correct side of the p.c.b? As you’re reading the current correctly, it seems as if you have, but it’s worth asking, as it’s an uncomfortably common error.

i agree, not reading the ac adapter. checked the voltage on it, i got 11 volts (ac). got the adapter a long time ago, not from you guys. double check where i plugged in the ct, its in the right spot. maybe my soldering ??

checked my welds under the female plug on the sheild for the ac adapter. i got 11 volts there. my jumper pin that selects ether pin 5 or pin 10 is set to pin 10, is that correct ?? i just noticed i haven’t thanked for the help, thanks so far.

tried pin 5 instead of pin 10. still no joy. this does not look good, seems to be hardware related.

That won’t affect the voltage measurement. (I don’t know which jumper setting you need - it is spelled out I believe in “Resources”: EmonTx Arduino Shield - OpenEnergyMonitor Wiki

That’s exactly the conclusion I had arrived at. Email the shop: [email protected]
and provide a link to this thread.

done. i hope for the best.