Community
OpenEnergyMonitor

Community

EmonTx - a question about accuracy at low power

Tags: #<Tag:0x00007fc9c40b01b8>

When I used emontx to measure the power for example for microwave it gives me 500 watt and I measured the kettle it gives me 300 watt so the sum of them supposed to be 800 watt but If I measured them together it gives me 750 watt not 800 watt… Did anyone knows why?

Welcome, Shahd, to the OEM forum.

Which current transformer are you using? If it is the SCT-013-000, the accuracy is only specified and guaranteed over the range 10% – 120%, i.e. above 10 A. Both your loads together do not draw 10 A, so I think that is the most likely explanation.

Thank you Robert for answering… I sent you the picture below of 3 devices I have measured with emontx and using SCT-013-000… the first 3 columns from the left are the values of each device that were measured alone, the predicted values mean that are the values that I expect through the addition operator, and finally the actual values mean that are the values I have measured together… also realize the difference between the average of predicted and actual.

Those numbers are the real power in Watts?

Have you calibrated your emonTx - especially for phase error? Your kettle and grill are likely to be very close to unity power factor, the microwave is likely to be somewhat less than unity power factor. One way to check this will be to measure the combination of kettle and grill. It those add up to near to the measured total, then I suggest you should adjust the phase compensation in that channel (because the phase error is particular to the combination of current transformer and a.c. adapter) so that you get the highest real power (or highest power factor if you can display that - it’s calculated and available from the library) on those purely resistive loads. The full procedure is in the ‘Learn’ section here, additional notes if you are using monLibCM are in the documentation for that.

The phase error of both current transformer and a.c. adapter does vary according to the manufacturing batch, so it’s not something that we have any control over.

No, I haven’t calibrated the emonTx… I used the built in code… I will send it to you:

I tried to send you the code but it keeps giving me that the new users can’t post more than 2 links

Hi Shahd,

I bumped your account up a notch. You should be able to post your links now.

This the combination of Kettle + Grill as in the picture above that now I sent it

We know what the default sketch is. What you need to do - and you can only do this if you have a programmer - is to enter the “on-line” calibration mode at power-up. It can be adjusted there.

Those values are much closer - within about 1%, which I think is reasonable given that “full scale” is 23 kW.

So it looks as if the power factor of your microwave oven is indeed showing up an error in the phase correction.

Thank you Bill very much

I have a programmer…Thank you Robert very much I appreciate that

Sorry for bothering you Robert… One more question: the truth is that I want to know how can I enter the “on-line” calibration mode

Or you connect a Pi to the serial output :grinning:.

Do you have a recent sketch in your emonTx? - when did you buy your emonTx?

If you connect the programmer (using the Arduino IDE) and power it while looking at the serial monitor, you will see the instructions.

If you have an older emonTx and sketch (bought before 18 October 2019), then it will not have on-line calibration, and you will need to edit the sketch, compile and upload any changes.

EmonTx code.txt (23.2 KB)

yes I bought it before 18 October 2019… And I have the sketch I sent it now to you

That is not complete - many lines are missing at the beginning.

However, the line you need to change is
const float phase_shift= 1.7;

Change the number 1.7 a small amount each time.

If you can add, inside loop( ), for the c.t that you are using
Serial.println(ct1.powerFactor);
and adjust phase_shift so that the power factor is as close to 1.0 as possible, then that is the best you can do.

@borpin
How do you do that?
My Pi’s are serially connected as a matter of course.
Thx