Emonth v1 humidity completely wrong

hi, I have a emonth v1 unit with dht22 sensor, it has worked fine for about 8 months but now the humidity values are completely wrong, I use the official sketch, just modified the sample interval from 4 to 5 minutes.
When the weather is quite dry it drops to one, when the weather is wet it goes straight to 99.9,
I’ve tried to increase the sampling delay in the sketch but no change. I think that the sensor dht22 has gone. :sob:
Look at this graph

Looks like a faulty DHT22 sesnsor, we will send you a replacement.

thanks but I wanted just a confirmation of my analysis, I want to try to use a BMP280 instead because I’d like a pressure sensor too.

Thanks, I’ve received the replacement (two of them) and it works fine. I still want to try a BMP280 asap I receive it.

I’ve seen that you evaluated that sensor, ave you ever thought to a version of emonth with pressure sensor ?

The BME280 was a bit expensive for us, see my comparison table: emonth2/sensor at master · openenergymonitor/emonth2 · GitHub

Hi all,

Same for me. I think the humidity value not right. I can’t upload screenshot. Sorry.

What do you think?


Hi Lolo,

I adjusted your user account. You should be able to upload now.


Thanks I upload :
capture_emon.pdf (166.5 KB)

Just one thing, Emonth is in my garage.

Thanks for all.

I don’t think this is the same issue I had, it seems your garage is quite dry but do you have any hygrometer to check ?

There is discussion about calibration of temperature and humidity here: Calibrating Temperature Sensors | Archived Forum
I found a Wikipedia article about using a concentrated salt solution to create a reference humidity value.