Community
OpenEnergyMonitor

OpenEnergyMonitor Community

EmonTH solid green led, no data

Hi! I am trying to reconnect an emonTH v 1.5 (I think) after a long period of time. Batteries were dead for quite long. The led turns on when batteries are inserted and it won’t go off. The sensor appears on inputs but no values are fed (n/a NULL is displayed). I didn’t change the node config (on on for 26). A second TH is working OK.

I just flashed and updated the emonpi and looks like everything is OK.

Any idea on what can be happening? Thanks!

It could be many things - the LED is turned on very early in the setup & initialisation, and turned off at the very end.
But - can you explain this a bit more:

Do you mean that on the Inputs page of emonCMS, a zero value appears and is updated roughly every minute?
Is there any sign of data from it in emonHub log? If so, what?

Do you have a programmer you can connect, so that you can check the serial output? If so, can you report what you see?

In the emonCMS inputs page, NULL appears on where all the values should be, n/a in the time column, where the seconds should be.

No sign of emonth8 on emonHub log, but it does appear on the inputs pages as stated.


emonth7 is the one working

I tried restarting enomHub and power cycling the emonpi, also powering off the emonTh several times.

I dont have a programmer.

Thanks!

Without a programmer to see the messages it generates as it starts up, there’s not much information to go on, I think the likeliest, though not a certainty, is the radio itself has failed.

You could try emailing the shop: [email protected] and mention this thread. I don’t know what the policy is regarding repairs, I think it’s worth asking.

I was checking the pins to consider getting a USB programmer and then I thought I hadn’t tried the mandatory whacking it against the table, which I did. The LED turned off, I thought it was GAME OVER, but it has been properly working since then (few days ago).

Thanks a lot for the replies.

Hmm…
Check for dry joints, or tarnish/corrosion on the sensor pins.
If it’s a “black blob” RFM12B, those are said to be unreliable, so it might still be a faulty radio.

I wouldn’t like to say how long it will continue to work.

This one was outdoors (partially covered) for more than a year, it might have some corrosion. How can I determine if it is that particular version?

I’m not with you there. You can tell the radio version by removing the cover and looking - there are pictures of all the versions of the radio modules we have used/do use in the ‘Learn’ section. But to find the version of the emonTH itself, that’s on the underside of the p.c.b. and you’ll need to remove it from the case to see. It’s only 4 screws, but they’re small and fiddly.