Community
OpenEnergyMonitor

Community

EmonTH setup

I’ve been running an EmonPi for a number of years and am trying to add an EmonTH to measure my hot water cylinder temp to make decisions about whether to divert power to car or hot water. The TH fired up straight away and is returning values for Temperature (around 22 degrees - ambient temperature of the cupboard) and also humidity and battery voltage but Zero for External Temperature which I assume is the value for the wired sensor in the tank access tube.

Any pointers would be much appreciated, tia.

First question, is it a recent emonTH, and did you connect the external sensor before you put the batteries in? If not, take the batteries out for a few seconds, then try again. The external sensor is only detected at start-up, if there isn’t one then, it’s forever ignored.

Thanks Robert
Brand new emonTH, they’d connected the sensor before sending it & I’ve checked the connections. I fitted the batteries with the sensor connected, I’ve tried pulling the batteries out for a while and then replacing them but still zero. Do I need to delete the feed maybe?

That’s unlikely to help - the screenshot shows a solid 0°C came in 41 s ago from the emonTH, so the problem is the emonTH isn’t seeing and reading the sensor.
The value that’s transmitted is initialised to zero when you put the batteries in and the software starts up. It searches for sensors and if it doesn’t see one, that value stays at zero. You’re seeing exactly that.

You’ve definitely got it connected like this? https://wiki.openenergymonitor.org/index.php/EmonTH_V1.5#External_DS18B20_Temperature_Sensor_Connections

And the hopefully stupid question: the wires are stripped back far enough?
(I ask because I once spent half a day finding a fault which was exactly that - done by a professional wireman.)

Does the LED come on for 5 s when you put the batteries in, then go out?

If you have a programmer, plug that in and see what the monitor shows at power-up. Or if you’ve got a multimeter, measure across the red and black wires (3 & 6). You should see about 3.3 V for a very brief moment at power-up, then every time it tries to read the sensor (i.e. about every 55 s).

If it still refuses to cooperate or you aren’t able to check anything else, then I suggest emailing the Shop [email protected] and link to this thread.

Thank you Robert, great tips
Yes red & black are wired correctly, I’ve undone & redone just to be sure
LED comes on at startup
At startup my multimeter measures only a fraction of a volt across the terminals, it ranges between 0.3 & 0.8v and only for a second. I don’t get a voltage reading at 55s intervals - steady 0v
I’ll email support
Cheers
Jeremy

Sorted - Robert you were spot on, the white wiire wasn’t connected and was doubled up into the heatsink so I couldn’t see it. All working now. Many thanks.

1 Like

I wondered what you meant when you referred only to the red and black. The white wire is the the one that carries digital data to and fro. Hardly surprising the sensor didn’t answer and send back a temperature, it was sitting there thinking “Is the emonTH self-isolating?”

(And watch your spelling corrector - it’s heatshrink. You had me fooled for a moment.)

Definitely one for @Gwil to look into.

Very sorry about that, Jeremy - that’s my fault. I clearly didn’t attach it properly. I tested the emonTH together with the sensor before shipping (checking the serial output from the emonTH), so it has worked itself loose on its journey to you.

Glad you have it working.

1 Like

When I was doing my student apprenticeship, a wireman taught me to always do the “tug test”: After you’ve made the termination, give it a sharp tug (the strength depends on the wire size, of course). If it doesn’t come out, it’s OK.

Thanks, Robert. I think I’ve been tugging on all three wires at once. Since the white is in the middle of the other two, it has a bit more slack. I’ll be more thorough in future.

You mean you don’t adjust the length according to how far it’s got to reach? :roll_eyes:

 

:wink:

When there’s a few wires close together, I usually start in the middle.