emonTH-data doesn´t appear in local emoncms input page

Hello everybody,

I just purchased a new pre-configured emonPi and an one emonTH. The emonPi with its two current-, one temperature- and one voltage-sensor works completly fine and data can be visualised using local emoncms.

I just have problems with the emonTH. The description follows:


  • emonTH doesn´t appear in local emoncms input page although hardware seems to be working


  • Version: emonTH V2.0.2 Sep 2016
  • RF node ID: 23 (DIP-Position: off, off)


  1. emonPi is connected to WiFi, emoncms can be accessed via browser, emonPi appears in inputs, feeds work, everything great so far :slight_smile:
  2. I put batteries in the emonTH: green LED switches on for a couple of seconds then extinguishs as described in the guide → so hardware should work :slight_smile:
  3. Problem starts here :frowning_face:: No automatic appearance from emonTH in local emoncms input page
  4. I updated the emonPi
  5. I restarted the emonPi a couple of times
  6. I restarted the emonTh a couple of times (took batteries out and in again)
  7. Still no change: emonPi still works fine, but no appearence from emonTH in local emoncms input page
  8. The only time the emonTH was visible in the log was with the following content:
    2020-01-05 17:44:47 440 DEBUG RFM2Pi 4 Timestamp : 1578246287.44
    2020-01-05 17:44:47 441 DEBUG RFM2Pi 4 From Node : 23
    2020-01-05 17:44:47 442 DEBUG RFM2Pi 4 Values : [21.1 0 45.8 2.6 1]
    2020-01-05 17:44:47 442 DEBUG RFM2Pi 4 RSSI : -27
    2020-01-05 17:44:47 443 DEBUG RFM2Pi 4 Sent to channel(start)’ : ToEmonCMS
    2020-01-05 17:44:47 443 DEBUG RFM2Pi 4 Sent to channel(end)’ : ToEmonCMS
    2020-01-05 17:44:47 645 DEBUG MQTT Publishing: emon/emonth5/temperature 21.1
    2020-01-05 17:44:47 647 DEBUG MQTT Publishing: emon/emonth5/external temperature 0
    2020-01-05 17:44:47 649 DEBUG MQTT Publishing: emon/emonth5/humidity 45.8
    2020-01-05 17:44:47 650 DEBUG MQTT Publishing: emon/emonth5/battery 2.6
    2020-01-05 17:44:47 652 DEBUG MQTT Publishing: emon/emonth5/pulsecount 1
    2020-01-05 17:44:47 654 DEBUG MQTT Publishing: emon/emonth5/rssi -27

Could it be the low Signal-Strength of -27? (although the emonTH was directly positioned next to the emonPi)

Can anybody help me with how I can fix the issue?


hello @immanuel does the emonth only appear once in the log? signal strength looks good

For reference more than anything else, as I’ve noticed this question pops up from time to time.

-27 is an excellent Received Signal Strenght Indication. (RSSI)

It’s counter-intuitive, as it appears that a value of -50 represents a stronger signal than say one of -25.

It’s actually the opposite.
As the RSSI value becomes more negative, the signal strength it represents becomes weaker.

1 Like

hello @TrystanLea,

yes that was the one and only time the emonTh appeared in the log.
Today I again took the batteries of the emonTh out and in again a couple of times while the emonPi was running. But still no input and nothing in the logfile :frowning_face:

Yesterday the emonTh appeard once in the emoncms input page but just with one initial value and afterwards it was offline and didn´t sent anymore data. I then deleted the emonTh device from the emoncms input page.

Was that an error? Should the emonTh, now after deletion, nevertheless appear automatically in the emoncms input page.

Hello @Bill.Thomson,

thanks for the explanation :slight_smile:

1 Like

Yes it should. As this is new I’d be inclined to contact the shop directly - it could well be faulty.

Yes please drop us an email at [email protected] with your order number and @Gwil will get another sent out to you. Sorry about the trouble.

Hello @TrystanLea,

alright I will do so and contact Gwil. Thanks for the quick support :slight_smile:

Hello again,

after contacting the support I received a new emonTH beginning this year. But I just tried it out now. Unfortunately it still doesn´t work with the new emonth.

Here the problem-summary:

  • hard-ware:

    • emonPi with one temperature-sensor, two ct-clamps and the voltage-sensor
    • first emonth: emonTH V2.0.2 Sep 2016
    • new replaced emonth: emonTH V2.0.2 Sep 2016
  • problem:

    • emonpi is up and running with all sensor-data coming into emoncms input-page correctly
    • emonTH:
      • after I put the batteries in, the LED of the both the first and the replaced emonTH switches on and switches off after a while (as explained in the guide)
      • but none of the emonTH appear in the input-page of emoncms
      • and none of the emonTH even appears once in the logfile of emonhub
      • i tried it various times to take the batteries out and in again while the emonpi was running, but always the same result as explained above

Any ideas how I can find a solution to this?


Any luck yet?

Welcome, Aiden, to the OEM forum.

Any luck with what? If you’re referring to Immanuel’s problem, he hasn’t logged in since May 2020, so we don’t know if the problem is solved or not. Do you have a similar problem? If so, we can only help if you describe what it is exactly that seems not right.