Community
OpenEnergyMonitor

OpenEnergyMonitor Community

EmonTH accidently got wet & not transmitting

One of our EmonTH got dirty & a bit wet; unfortunately, the protective plastic slipped a bit while sandblasting old beams nearby with a pressure washer and stuff got in.
Though it continued working for 4-5 hours.
Stupid I know, should have moved it, but I’m using it for pulse counter on water meter.

Started cleaning it up, batteries seem ok, when putting them back in the green light stays on rather than turn off after short while & nothing being received by emoncms.

Wondering if it wouldn’t be easier/safer to replace it, ideally with one configured with same ID so it hopefully picks up from where this one died off (emoncms feeds & nodered flows configuration)?

Any thoughts or even comments on our stupidity welcome :slight_smile:

I would guess that water has got underneath the RFM69 module.

As you are prepared to replace it anyway, as a last resort I’d try washing it in distilled/de-ionised water, and leave it to dry in a warm place for several days, then try the batteries in it.

If you do replace it, then provided that the replacement uses the same NodeID, the count should go into the same input and feed.

Thanks Robert, will give that a try,

Hi Tom - did you have any luck fixing your EmonTH?

I have the same issue with mine and I’m loath to throw it away.

When I run serial debug I get:

emonTH FW: V324
No EEPROM config
Int RFM…

That only means that the EEPROM has not had a custom configuration written into it.
Do you see anything more after Int RFM...?
Does the LED come on and stay on?

Nothing appears after “Int RFM…”, no and the yes the LED comes on and stays on.

So it looks as if the radio module itself is not responding.

Have you tried removing any contaminants and then thoroughly drying it - by ‘thoroughly’ I mean for several days on top of a warm radiator? You need to get rid of any damp between the radio module and the PCB itself.

I’ve no idea how the humidity part of the sensor will react to getting wet, but that shouldn’t stop it from transmitting - which won’t happen until you get past “Int RFM…”.

Thanks Robert. I haven’t tried throughly drying it yet other than using a bit of kitchen roll. I’ve put it in the airing cupboard and will try again in a couple of days!