Community
OpenEnergyMonitor

Community

emonSD-26Oct17 to Emoncms 10.1.13

Tags: #<Tag:0x00007fc33adcf2d0>

Hi,

I have some doubts after do a big update in my emonSD installation.
It was running Emoncms 9.9.5, without problems.
Than I did the update to 10.1.13…

Most of my doubts are about interface than could anybody give me a quick feedback/help?

  1. Is there no more Configurations and Emonhub log view? I have not this option now.
  2. mqtt_input is always Activating Auto-restart, however all my inputs are from my MQTT breaker and still working fine.
  3. In MENU, bellow Schedule I have my Dashbards, however this item appears blank (no name or icon)… is there any way to solve this?

  1. When I select a Feed to see Data Viewer, the MAIN MENU (SETUP) is no more accessible, than I need to select My Account to access MAIN MENU again.

  1. /var/log/emoncms/ path is not available, than I needed it. But when I reboot my RaspPi it is deleted for a protection rule. How could I solve this?

And… this is always in my emoncms.log:

    > 2020-01-12 18:59:27.507|WARN|index.php|406 Not Acceptable|Theme/br/bNotice
    > 2020-01-12 18:59:27.605|WARN|index.php|406 Not Acceptable|Theme/br/bNotice
    > 2020-01-12 18:59:29.606|WARN|feed_model.php|Feed model: Requested feed does not exist feedid=31
    > 2020-01-12 18:59:29.602|WARN|feed_model.php|Feed model: Requested feed does not exist feedid=30

I am trying not to touch anything by myself and create something worst to solve.
Thanks a lot for any feedback.

Hello @all.mac07 how did you perform the update?

It looks like you have updated emoncms core but not the optional modules… Are you able to try the built in updater under Admin > Full update?

No… directly with git in my emoncms path.

You need to update all the modules as well in emoncms/Modules and others in /home/pi. Is there any reason you don’t wish to use the built in updater?

The update script does far more than just update the git repositories, so updating via git only is likely to cause problems.

2 Likes

Easy answer… it was not working. Nothing was updating.

Ah. Did anything appear in the update log screen?

Can you click on the button Copy as Markdown next to Server Information on the Admin page and paste into a reply here please (no further formatting required).

Did you try running the emoncms updater before running git pull on the emoncms repository?

I think it may be easier at this point to download the latest emonSD image from:

https://github.com/openenergymonitor/emonpi/wiki/emonSD-pre-built-SD-card-Download-&-Change-Log#emonsd-17oct19-stable

and the import via USB import method as documented here:
https://guide.openenergymonitor.org/setup/update/#upgrading-to-a-new-emonsd-image

1 Like

I did. But it was not going to any version newer than 9.9.5. The update result was… “it is already the latest version”.