emonSD-03May16 Release

Ah yes, this is MQTT not HTTP. This is why your browser would not work

New image has been launched, see blog post

The new image is now shipping by default pre installed on all emonpi and emonBase, together with a RaspberryPi :smiley:

Thanks lot for helping with all the never-ending testing and debugging. This is quite a milestone, since up until last week we were still shipping the last stable image from June of last year with emoncms 8!


Hi, congratulations for your work!!!

I have a problem, i want send the information to private server by 3G. All work well, but the data traffic is very high.
i put the “sendinterval = 300” and “batchsize = 200” to mi server the ip conections is every 5 minutes.
But i put iptraf program and i can view that emonbase send information to and recive traffic of
any idea to eliminate this traffic???

Thanks for all!!!

Is the emoncms.org SSL port so if you do not want to send data to emoncms.org just remove the emoncmsorg interfacer from emonhub.conf or disable it by commenting out the interfacer type eg

    #Type = EmonHubEmoncmsHTTPInterfacer
        pubchannels = ToRFM12,
        subchannels = ToEmonCMS,
        url = https://emoncms.org
        apikey = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
        senddata = 1                    # Enable sending data to Emoncms.org
        sendstatus = 1                  # Enable sending WAN IP to Emoncms.org MyIP > https://emoncms.org/myip/list
        sendinterval= 30                # Bulk send interval to Emoncms.org in seconds

The # before “Type” will prevent this interfacer being created.

The traffic on is Orange (Spain) ISP’s DNS lookup so (assuming that’s your ISP) you probably need that unless perhaps you are sending to a domain (your private emoncms server) that has a fixed IP address in which case you could try replacing the domain name in the url with the IP address in emonhub.conf to reduce the need to look it up.

If you would rather send data to emoncms.org over http rather then https you can change the emoncmsorg interfaces to http this should use less bandwidth but will obviously be insecure.

Have much data have you measured that the system is consuming?

Just tested the 03-May16 emonSD image works great on a Pi Zero! Emoncms, nodeRED and openHAB all work fine with 70Mb RAM to spare. Performace is surprisingly fast! Amazing, $5 of computer


Hi, I have an EmonPI with a RPi2 (Emoncms Version low-write 9.6 | 2016.05.11, updated from image emonSD-29Mar16).
If I replaced the RPi2 with a RPI3, would I need to reinstall everything on a new mirco SD card or could I just put the micro SD card on the RPI3 (maybe not very recommended I suppose)?

The 29March16 image supports the RasPi3 so you could just pop the SD card into the Pi3 and it should work fine.

However, the 29March16 image was a release candidate image. Several issues were fixed in the 03May16 release. I would highly recomend moving the the 03May16 image. The backup / import module (that’s pre-installed on the March & May image) should make migration very easy:

1 Like

Trying to update from a very old emonhub oemgateway image on my RPi but I just can’t get this new image to boot on a RPi B with a 4GB SD card.

Image checksum on download is fine, but flashed twice to SD card and each time the Pi boots into Emergency Mode.

As a last resort I’ve flashed to the June 2015 image and all is fine. Has something broken RPi B Rev 2 compatibility? I have the Pi B Rev 2 Made in China.

Latest image should work fine on a Model B. I have tested on a Pi zero. My suspicion would be that the flashing to your 4GB card did not work. Some 4GB SD cards are smaller than others and the image does not fully flash. Have you got a Linux PC you can insert the flashed SD card in to test? You should see three partitions. Alternatively you could try flashing to a larger (8GB?) SD card to ensure there is plenty of space.

Hi Glyn,

Downloaded this image & burnt to a SD. But when I run on an EmonBase Pi 2 - & it starts fine, but there seems to be a number of issues:

  1. On the ‘backup’ screen it’s reporting “Can’t connect to redis database, phpredis is not installed, see readme for redis installation” - tried re-booting no success.

  2. When I tried to upload “backup” file (22MB) it hung and then dropped out with no update (looks like it timed out) - so on a EmonBase am I supposed to do it manually?

  3. Tried to Putty into the user account user:password pi:emonpi2016 no luck - if I can’t SSH then I can’t upload and doing 2 is a non-starter.

In addition have tried to update the EmonTX to v3.4 - this is dropping of the network - so is this sketch for the Discrete Sampling working I’ve gone through the forums and its really confusing is 2.6 works or doesn’t is that the EmonPi or a previous version of EmonTX. Is v3.4 now working, but the 60s ‘soft-reset’ has been removed. The initial debug looks fine - but after 4 to 6 hrs it stops sending information.

So which one and should it work or am I looking at a hardware fault?



PS: I’m a fairly competent Linux/Embedded Systems hacker, but I’m getting lost trying to keep track of which GIT repository for which EmonTX & which EmonBase or EmonPi - & the links/articles from your main site are inconsistent.

Hi Kotik,

Sorry to hear you’re having trouble. There must be an issue with the what the image had been written to an SD card. I can confirm the image has been extensively tested on a Pi2 with no redis issues. The fact you cannot connect via ssh indicates there must be a fault. Can you try and write the image to another SD card and test with a Linux computer if all three partitions successfully mount. There should be a file called emonSD-03May16 in the /boot partition to indicate this is the correct image.

On first boot the image will auto-update to the latest version, please ensure the network is connected and wait about 5-10min for an update to complete on first boot only.

V2.5 is the current latest stable emonPi firmware. This will be updated automatically from the RaspberryPi when you boot the new image for the first time.

All current resources are listed on the resources page of the User Guide, follow this user guide to setup the new image:

HI Glyn,

Thanks for the fast response. Will try again to re-burn using the URL to download a new image etc.& not sure why that will fix a pi password problem for user pi, but to note on guide

emonSD Pre-built SD card
•EmonSD Download repository & changelog - links to a 404 page

Also just confirm is the emonTX v3.4 DiscreteSampling the working Firmware for the emonTX or should I use an earlier one?



Which page did you find the dead link on, please let me know so I can fix it.

Yes emonTX v3.4 DiscreteSampling is the current firmware for the emonTxV3:

It’s Resources - Guide | OpenEnergyMonitor > Software Resources > emonSD Pre-built SD card > EmonSD Download repository & changelog (https://github.com/openenergymonitor/emonpi/Docs/emonSD-pre-built-SD-card-Download-&-Change-Log)

Thanks fixed :thumbsup:

Upgraded emonpi to Pi3 and did a complete fresh install of the emonSD-03May16 release. Did a backup (before the upgrade), did the install, ran the update per the instructions, made sure everything seemed to be running (which it did), then ran the import from my backup.

That went well so I copied the relevant parts of my emonhub.conf (attached)emonhub.conf.txt (5.0 KB)

Rebooted, everything seemed to come online just fine except only two of my nodes showed up. The first node (5) is the local emonpi and another node that reads my garage temps showed up. All the rest of my nodes did not show up for some reason. I have looked at all the log files (syslog, emoncms.log, messages & emonhub.log), but I can see no errors at all that would point me in the direction as to why the rest of my nodes are not showing up.

All nodes were working fine prior to the upgrade.

I was hoping someone could point me in the right direction.



Looks like I just needed to restart all of my nodes physically (which is weird). Once I did that, all of them are showing up now.

Hi I also upgraded my emonpi from RPi2 to RPi3 and switched to the emonSD-03May16 release. Restored my emonhub from the backup and my openhab configuration files from a backup copy and everything is working fine.

Great Job.


1 Like

Thanks, good to hear :blush:

Good work setting everything up. :+1:

3 posts were split to a new topic: Install OpenHAB2 on emonSD / emonPi