EmonPi with Dataplicity no longer working

I believe it this happened this past Wednesday where it was working and now no longer does.

I have a EmonPi running at work and at home both with Dataplicity and both have been working for months.

Suddenly it no longer works and below is what I now get.
And I get this at home and at work.
But if I log in while on the same subnet it works as expected both at home and at work.

This leads me to believe:
-it is not EmonPi itself because it works if I type in their IP address while on their subnet.
-same symptoms at home confirm this is not something IT at work did.

I cannot find anything googling.
Any ideas?

Have same problem across multiple Emonpis on different networks. Worked OK on Thursday as I set up a unit. Didn’t work yesterday when I tried the same thing with another one. Then found a common problem across all Dataplicity linked devices.

Yes seem to have the same issue here. Looks like they are not translating the paths for css & js files as they where before…

I have the same here too. Spent ages faffing about rebooting everything before I had the sense to check here…!

Same issue here. I can log in locally but the emoncms phone app has connection error. Can’t even view the emon dashboard on my phone browser anymore.

Is there another free alternative?

One thing I could not figure out with Dataplicity is how to pass parameters (specifically the read only key) so that I could allow others to access the dashboard without having to provide credentials.

I think its related to the problem here:

They have it fixed for Home Assistant but you should send an email asking for help to their support team.
I am sure they will look into it.

@TrystanLea - are you following this up with Dataplicity?

I’ve messaged them and pointed them to this thread. Will let you know if I hear back

I noticed that it’s the browser blocking the css and js files as it says these are not being encrypted properly as per https requirements. It is possible to temporarily bypass but probably not recommended.


I’ve figured out a workaround.

We were relying on the $_SERVER parameter ‘HTTP_X_FORWARDED_PROTO’ or apache_request_headers equivalent to state ‘https’. For some reason this has changed and it’s coming through as ‘http’.

Parameter ‘HTTP_X_FORWARDED_PORT’ however is coming through as the correct port for https (443) and so I’ve added a check for this as well. If it detects either HTTP_X_FORWARDED_PROTO == https or HTTP_X_FORWARDED_PORT == 443, emoncms will now return paths with https at the start.

Here’s the commit with this change available in the emoncms master branch: dataplicity workaround · emoncms/[email protected] · GitHub

version 11.3.1 (master branch).


For a couple of years or more I’ve been successfully using …

It’s free for upto 5 devices

Here’s my ‘control screen’. If I click on HTTP at the far right for node 15 then the emon Data Viewer comes up. Another of the HTTP’s brings up the OpenEVSE charger for example.

1 Like


Our apologies for inconvenience you’re experienced caused by that issue, we already found it and have deployed a fix.
As pointed out by @TrystanLea, the issue arose from a recent infrastructure upgrade, which resulted in the export of HTTP_X_FORWARDED_PROTO http instead of https. Big thanks for your help. We appreciate it much.
Also thanks for everyone who pointed out the issue and reported it to us. It helped to solve the problem fast. Please not hesitate to contact us in future through chat on our main page in case of any problems or questions.

Dataplicity Team.


Thanks Grigorij for posting here and fixing this! Much appreciated!

1 Like

All good again. Thanks for sorting quickly.

1 Like

Thank you for everyone’s help.

I am happy to see it is working again.

Thank you for your comments Johnbanks.

So with Remote.It would I be able to provide a weblink using a read only API key to others?


I can’t answer yr question.
But these links might help …