Community
OpenEnergyMonitor

OpenEnergyMonitor Community

EmonPi WiFi USB Dongle no longer working

I wonder if anyone can suggest what’s happening here?
The story:
My emonPi worked very well since installation earlier this year until a half-hour blackout a month ago. The emonPi lives 30m from my router in a metal meter box, so I use a Ralink RT5370 usb dongle and a hi-gain external antenna. It all worked very well until the blackout. After the blackout, I re-flashed the SD card, and pulled in the upgrades. It works well now, including the onboard wifi. However, to use the wifi dongle, I have to stop the on-board wifi. I have tried two ways: dtoverlay=disable-wifi in /boot/config.txt and (separately) blacklisting the native wifi drivers in /etc/modprobe.d/raspi-blacklist.conf. This latter method is the method that worked all year.
Now the Ralink usb dongle refuses to connect to wifi. I’ve tried many things, many times.
This is the complete log from another attempt just now…

Nov 23 11:40:02 emonpi wpa_supplicant[389]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Nov 23 11:40:02 emonpi wpa_supplicant[389]: wlan0: CTRL-EVENT-TERMINATING
Nov 23 11:40:07 emonpi wpa_supplicant[1187]: Successfully initialized wpa_supplicant

The usb dongle is present on the system, and all drivers are up-to-date and installed. Ralink’s instructions have been followed and everything reports as fine. I’m currently using the disable-wifi method, but I’ve tried both, and neither works. Superficially, in the log it looks like the “disable-wifi” instruction is disabling the dongle (wlan0), but I get the same result (no wifi connection) when I blacklist the onboard wifi drivers.

Your thoughts and comments would be much appreciated. It’s got me stumped.

@AdeinFNQ

This works for me …
Turn off RPi 3 built in wireless by doing ….

sudo nano /etc/modprobe.d/raspi-blacklist.conf and then enter the following …

#wifi
blacklist brcmfmac
blacklist brcmutil

It will require a reboot