Community
OpenEnergyMonitor

Community

Emonpi stops firmware update

My emonpi & TX3 have worked without intervention for ages. I recently logged on and selected "full update " option. All started well but the display stick on “rebooting do not unplug” This stayed for days. During this time my dashboard still operated so I was able to do my usual monitoring. I do not seem to be able to get out of this. Any suggestions?

The text below was copied using the paste to clipboard option. Also admin display service runners starting.

LAST ENTRIES ON THE LOG FILE
Starting update via service-runner-update.sh (v2.0) >
Filesystem is unlocked - Write access
type ' rpi-ro ' to lock
- emonSD version: emonSD-07Nov16
ERROR: emonSD base image old or undefined...update will not continue
See latest verson: https://github.com/openenergymonitor/emonpi/wiki/emonSD-pre-built-SD-card-Download-&-Change-Log
Stopping update

service-runner: Activating Auto-restart

Hi, please read the pinned announcement.You will need to start with a fresh SD Card. emonSD-24Jul20 release.

Hi,

Thanks for the quick response. – I assume I will have to start from scratch and rebuild feeds from Pi and TX3 and re create my dashboards.

Assume nothing :rofl:

No you can simply import the data. follow the updating link from that post https://guide.openenergymonitor.org/setup/update/#upgrading-to-a-new-emonsd-image.

Hi
Have followed the guidance and re-imported my original setup. All working properly again. Apologies for not finding the stuff myself. Everything has worked fine for a couple of years so was a bit out of practise with the details of setup etc. Thanks for your help and the whole system is great.

No Bother :grin: