Community
OpenEnergyMonitor

Community

EmonPi (RPI3B+) not connecting to wifi

(Olav Kristiansen) #1

I know there have been posts before on similar issue, but I created this because they seem to be RPI 2B. I just procured an EmonPI solar PV bundle, which is specified to be a 3B+.

I am not able to connect to my home wifi. The emonpi boots just fine, and is able to find the correct SSID (I see this by being connected via ethernet cable). But it does not seem to be able to connect anyway, even if I have typed in and verified the correct password. Both SSID and PW consist of regular letters and numbers.

I am fairly new to RPI (and Linux) world. Can anyone point in the right direction, or even better, a step-by-step description on how to solve this problem?

(Brian Orpin) #2

Hi, can I check, you are seeing this information on the WiFi config page?

What error are you getting?

Have you tried to reboot your WiFi router?

(Olav Kristiansen) #3

Hi, yes I can see all the right info on the wifi config page. It lists all the SSIDs I expect. But at very low signal strength, which is weird. It lists -81 to -85dB, while my mobile lists full connection and -45dB at the exact same spot. Which is same room as the wifi AP, about 3m from (nothing between).

I don’t get any error message. The config page pop-up says “wait 60s” after I have typed the pw and clicked save. Then nothing. And it does not respond to the refresh button.

No, I have not tried rebooting the wifi. No other users had any problems, so it didn’t occur to me. I will try that tonight.

(Brian Orpin) #4

Larger negative number, in this case, means a better signal.

Firstly there does seem something odd with the WiFi but that may be unrelated.

Click on ‘logout’ - what do you see?

(Olav Kristiansen) #5

First: How do you include quotes in this forum…?

I thought the decibel scale was the opposite as for audio? That it goes from 0dB (max) to minus infitiy (minimum strength)? I need to google it. Anyway, I do not understand the HUGE difference between two users. THe wifi is working very well, 99% uptime, no kids complaining etc. Low latency and no jitter, usually >>150Mbps transfer. Mesh network.

I’ll check the ‘logout’ tonight and report back.

(Brian Orpin) #6

Highlight the text you want to quote. The site is a Discourse site so this guide may help.

You may be right - me and things like dB don’t generally agree :frowning:.

WiFi networks do vary in quality so sometimes it is the right thing to do.

I do think there is something not quite right with the WiFi admin. I found if you deselected all the SSIDs and saved that config, it still worked on the WLAN IP address and checking ifconfig from the command line showed the wlan still connected.

However, when I then tried to log on (using that same WLAN IP) it asked me if I wanted to continue by Ethernet/WiFi etc so the connection was still up.

(Robert Wall) #7

You are indeed correct, Olav (and sorry, Brian). -81 dBm is a lot less than -45 dBm.
The decibel is a purely relative measure of power, unless by convention a reference level is implied.

@Bill.Thomson is the expert here, I believe the reference level (0 dB) for r.f. work is 1 mW in 50 Ω

However, it’s likely that the actual measurement is a voltage relative to some arbitrary value, but the principle remains the same. Negative values are below the reference level, positive values are above.

1 Like
(Bill Thomson) #8

0 dBm is probably the most commonly used reference, but yes, it is indeed 1 mW into a 50 Ω load.

(Olav Kristiansen) #9

Hi, just rebooted the entire mesh wifi network (even if it works fine), the home router and even the ISP router (which is doing nothing here, it is bridged).

After rebooting the emonpi, I clicked “Save and Connect”, then refresh. Three times. Each time, after about… half a minute or so, status changed from Disconnected to Connected for about 10 sec, then back to Disconnected.

This is the screen report:

Status: Disconnected
IP Address:
Mac Address:
Sub Net Mask:
Rx Packets: 25
Tx Packets: 24
Rx Bytes: 2475 (2.4 KiB)
Tx Bytes: 3816 (3.7 KiB)
Bitrate: 6 Mb/s
Frequency: 5.26 GHz
Link Quality: 62/70
Signal Quality: -48 dBm

No IP adress appeared in the report during the Connected period. There is a MAC address, I just removed it in this post.

What I do see, is that the signal strength in the report is in the excpected range (-48dBm), while in the SSID list, it says -75dBm (earlier also -81dBm). So there is something fishy there, but I do not believe it is my wifi.

(Brian Orpin) #10

If you untick all the SSIDs in the WiFi page, and click save, it should think it is disconnected from the WiFi (actually the connection is still active). However, if you ‘Logout’, you should get a page offering to connect to the WiFi.

Fill in the details there and see if that works.

(Olav Kristiansen) #11

Tried this just now several times, but no luck. Un-ticking all boxes, click save, and then logout, it asks for wifi credentials again, then reboots. Same result.

I also tried connecting to our guest wifi network, same result.

(Brian Orpin) #12

All I can suggest is SSH in and use the Raspbian tool sudo raspi-config, and see if that works.

What does ifconfig give you?

[edit] Seems sudo rfkill unblock wifi may be what you need.

[edit2] Is the country correct in wpa_supplicant.conf
https://www.raspberrypi.org/forums/viewtopic.php?p=1289912

(Paul) #13

Hopefully a daft question, but have you removed the Ethernet lead? It certainly used to be the case that emonPi/SD would not connect to WiFi whilst Ethernet connected unlike other Raspbian based images.

1 Like
(Brian Orpin) #14

Interesting. I was already connected to WiFi and then plugged in a cable and can communicate via either IP quite happily.

From digging around, I do think the country setting is the most likely reason for the problem. If so, I think the shop should put in special instructions for non-uk sales to connect to the EmonPi by SSH and run the raspi-config to setup localisations.

(Olav Kristiansen) #15

I was sort of hoping that I should avoid that, but I see that I will need at some point to do it (I am really not a linux-expert. Almost in the other end of the scale).

I haven’t actually tried unplugging the cable… Will try it. My experience is that a computer is capable of working on multiple networks simultaneously, so it didn’t occur to me.

Second that. A step-by-step instruction for us script-noobs would be appreciated. Is there any such “manual” to be found somewhere? I ask because I do not really know what to search for.

(Brian Orpin) #16

First the issue is that, if you boot a vanilla Raspbian up, it will ask you to set various things according to where you live. Because this image has had its first boot, those things do not get asked. For a UK user this is not an issue generally (except for timezone), for users in other countries, it can be (as you have found I suspect).

There are instructions on how to SSH in to an EmonPi here.

You then want to use the Raspbian config tool raspi-config. Documentation on this is here.

to start use

sudo raspi-config

I suggest you need to change

  1. Country
  2. Timezone
  3. WiFi country
  4. Setup the Network from this config tool.

The last one just may prove easier.

I am still guessing this is what is causing the WiFi issue.

(Olav Kristiansen) #17

Finally got around to try all the suggestions
Did this:

Setting time zone to Oslo and Wifi country to NO, but still locale to “en_GB.UTF-8 UTF-8” as there was no closer one.

and this:

No luck, everything’s the same. Anything else I should try?

(Brian Orpin) #18

Did you try to setup wifi from sudo raspi-config?

(Olav Kristiansen) #19

Yes, did that.

(Brian Orpin) #20

Did it give any error messages at all?

What is the content of

 cat /etc/wpa_supplicant/wpa_supplicant.conf