EmonPi not feeding into emoncms on docker

After several nights I managed that emoncms is running on docker at a new Synology again. I also managed to do a onetime sync via the sync module from the old docker installation on ubuntu to the new Synology docker implementation. The nodered integration is working again and it delivers data. The issue now is that emonpi is not able to write his data to the new emoncms on the synology. I always get in the emonhub log:
2022-03-31 16:25:57,118 WARNING emoncmsorg emoncmsorg couldn’t send to server: HTTPConnectionPool(host=‘’, port=8090): Max retries exceeded with url: /input/bulk.json (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x7573bb30>: Failed to establish a new connection: [Errno 111] Connection refused’))
I copied the new API Key and the new address and port to emonhub config at emonpi. I there something I need to do at emoncms? The firewall of the Synology is open. I can’t start emonhub on the emoncms docker installation - could this be an issue? Thanks a lot for your help!!!

Is there any help? Thanks a lot!

I think @glyn.hudson is your best hope for this.

Thank you Robert!
@glyn.hudson - do you have any idea? I did the emoncms feed test and it worked… When I point emonpi to the old docker installation (emoncms 10.2.6) it works - as soon as I point it to the new docker installation on the Synology (emoncms 11.07) it doesn’t. EmonPi is on low-write 11.0.5. I restarted emonpi several times. tried to backup and restore the 10.2.6 emoncms installation (I was not able to make it run) - So I ended up in a fresh docker install and I installed the sync module in the container - so a one time sync was successful. Emonpi has access to the new IP address on the Synology . Thank you very much for your feedback! BR Gerald

restarted the emonhub service on the emonpi and now it looks that emonpi is sending data to the new emoncms. But there is still the issue that I don’t see any input of emonpi in emoncms. Is on the emoncms emonhub needed to receive the data?

So found whats wrong- the sync seemed to mix up inputs- so I found now every input but needed to correct all the input operations.