emonPi LCD not displaying energy usage

Hi,

I’ve had an emonPi running for quite a while now and until recently things were going well.
However I noticed that the display on the unit is no longer giving a readout for energy usage 0 it just displays as though no sensors are attached. All other display functions are ok (uptime, ip address etc).

The sensors clearly are attached since data is getting posted to emonCMS.

Has anyone an idea of what might be going on?

Have you tried shutting down then power cycling the unit? Hard to tell without debug. Does the LCD display the SD card version number date? All sensors need to be connected when the unit is power up

Hi, yes I tried power cycling - no effect.
The display does not show the version number - does that come in a later version?
The sensor was connected when powering up.
Thanks!

Yes if version number is not displayed then you have an older version. That is fine, just building up a picture. Does the LCD indicate direction of CT sensors at startup?

You say the data appears in emoncms. Is this emoncms local, or remote emoncms.org? Can you log onto the local emoncms and run emonpi update in the admin menu. Please make a copy of the update log

On boot, it does mention the version, sorry. It’s V2.00.

On startup it says CT1 detected (that’s all I have connected).
No mention of current direction.

Oops - I’ve forgotten the password for my local emoncms instance - is there a way to reset it?

Great, do you have an AC-AC voltage sensor adapter connected? If so maybe it has malfunctioned, do you have a multimeter you could use to measure the 9V AC output of the transformer?

Yes, but it does involve SSH I’m afraid:

The sensor adapter is connected and it reads 11.5V AC when teating with my multimeter.
Thanks for the link about password reset, I’ll take a look.

A post was split to a new topic: Older emonPi (pre May 2016) reset Emoncms local password

You should see AC wave detected displayed on the LCD at startup. The AC-AC adapter needs to be connected when the units is powered up. What does the value from VRMS read?