Community
OpenEnergyMonitor

OpenEnergyMonitor Community

EmonPi and SSH

Tags: #<Tag:0x00007f88c030d4a0> #<Tag:0x00007f88c030d3b0> #<Tag:0x00007f88c030d270>

Hi!

My emonPi password isn’t working… when I try to connect via terminal SSH.

EmonPi is 150 km away from me and I can’t push button to allow SSH.

I have access to local network with EmonPi via VNC installed on separate raspberry Pi.

It there anything I can do to turn SSH on remotely?

Hi Dmitry,

For ssh you log in as ‘pi’ and the password is emonpi2016. This caught me out a few times - I tried ssh’ing using the credentials that I used for the web interface, but they won’t work.

Have a look here for instructions on how to enable SSH remotely, but unless you can access the file system you could be out of luck on that front.

Hopefully it’s just a matter of using the wrong credentials and you can get in using ‘pi’

David

David,

Thanks a lot for a good advice. It worked out. I wrongly used CMS login credentials.

It might be worth installing a pair of key files (with “ssh-keygen”) on your computer and on the Pi. Then the computer can authorise itself (especially if you don’t set a password on the key file itself). You need SSH and SCP on the computer, and you need the SSH password only once to set this up, thereafter it uses the key file pair as an alternative.

ssh-copy-id makes installing ssh keys to a remote system fairly easy.

Ref:

It’s part of the ssh “package” so is available if ssh is installed.

Thank you.