EmonEVSE stuck (since 8.2.3)


i have an EmonEVSE (type 2) since a few months. I bought it with a 8.2.2 firmware and a 4.1.7 Wifi firmware. I upgraded to the 4.2.2 firmware and it was working for the next weeks.
I did upgrade to 8.2.3. It was working at first, but I found the EMonEVSE stuck a morning (a few days after). The display was strange (luminosity very low and not all the characters were at the same luminosity). The web app was down. A electric shutdown and reboot did nothing. Same state after that. The car does not charge. I can see on the display (even if its weird luminosity) that it was not sleep during the day as usual (I set a time to wake up at 00:10 and sleep at 07:00).
Finally, I tried to flash again the 8.2.3 firmware. After that, everything was ok again. It worked for more or less 2 weeks.
And now it happens again. I did not flash again the 8.2.3 firmware. The EVSE is stucked right now. Is there anything I can check to find the reason of this issue ?

The problem has nothing to do with the firmware. It’s about hardware. An hour ago, i decided to downgrade to 8.2.2. As soon as I unscrew the case, it worked again with 8.2.3. If I remove the cover with the wires still in place, I can see everything seems ok. The OpenEVSE is up and running. If I move a bit the cover, while still separated from the back, openevse is rebooting. It might have something to do with the wires. But this is strange as all the connectors are well inserted (tried to pull them and push again with the openeves).

Oh dear, sorry to hear. Please contact support to resolve this [email protected]

Thanks for the email address. I will contact the support.