Community
OpenEnergyMonitor

Community

emonESP not finding wi-fi networks

(Stuart Reid) #1

This may or may not be relevant, but prior to putting the emonESP module onto the emonTX I uploaded the 3-phase sketch v14.0 from the hex file on Git.

On power-up I can find the ESP and join its network using IP address 192.168.4.1

However, it will not find any wi-fi networks, showing “Mode: Unknown (ERR)”

I’ve tried selecting the ‘factory reset’ option.

Version is 2.3.0

Thanks in advance

Edit - resized image and attached it to post. BT - Moderator

0 Likes

(Robert Wall) #2

The 3-phase PLL sketch is here. You will almost certainly need to compile it yourself, having chosen the configuration options to suit your application. If you download the .zip file, you will also have the supporting documentation.

I’m afraid I can’t help you with the ESP8266 - I know nothing about that.

Please don’t link to files on external sites. Unlike others, we want you to attach your screenshots, log files, etc to your post. If the external site goes away, the material is likely to be lost forever. If that happens, when someone reads your post, your question and our answer will have little or no value.
If you need to post more than one attachment, tell us you have more information to post, and we’ll change your user account settings to enable you to do so.

0 Likes

(ian) #3

I have had difficulties with EmonESP Wifi.
It is invariably because the ESP is not clean. Wifi information is retained when you upload new firmware. I always erase any ESP before uploading.

$ esptool.py erase_flash

*`sudo`  maybe be required*

This works 100% for me.

0 Likes

(Stuart Reid) #4

Thanks for the reply, but it’s not the emonTX sketch that I am struggling with, it’s the ESP itself.

Apologies for the external link, I couldn’t see how to attach an image. Is it enabled on my account?

0 Likes

(Brian Orpin) #5

Just paste it in.

0 Likes