EmonESP + EmonTX v3.4 - power readings zero/anomalies

Ciao everyone from Italy!

I am Marco and got my first EmonTX v3.4 back in 2015, it worked like a charm for a long time, but then somehow the RF module was interfering with our electric gate (I guess they worked on the same 433 Mhz freq), so I switched off the emonTX and forgot about it.

Now 5 years later being in forced quarantine I re-discovered this world, and with much surprise I found out that the emonTX can now work with ESP8266, bypassing my aformentioned RF problem. Huge thanks for this, you guys are really awesome.

So I proceeded with updating the emonTX:

  • I am using the latest firmware of continuous monitoring, uploaded with Plaftorm.io
  • I am using EmonESP on a NodeMCU v3 (works like a charm, btw), fw uploaded with Plaftorm.io
  • I am using a 5V DC PSU able to provide 2A for powering the emonTX + emonESP
  • I am also using a 9V AC/AC adapter for current sampling
  • I’ve connected 3 x CT of the type SCT-013-030 on CT1, CT2 and CT3 (fyi I already removed back in 2015 emonTX on-board burden resistors to compensate the fact these CTs aleady have burden resistors)

I then configured emonCMS and MQTT and they work fine.
I immediately noticed some anomalies on the readings I got, so after a few days I re-read the wiki and forums a bit better and noticed I didn’t do one important step.

So yesterday I did the following:

  • I removed the JP2 so I am using EU plug AC/AC adapter for AC sampling
    In that occasion I also did:
  • Wired a DS18B20 temperature sensor to the emonTX board

Re-powered everything, worked like a charm for a few hours.

Now comes the strange part. I noticed at first that I got all power readings to zero - while temperature reading was fine. My first thought went to a potential lack of power - in fact I also added a new temperture sensor to the setup - so I switched to a more powerful PSU: now the emonTX + emonESP is plugged to a 5V DC 2.4A.

But I am once again receving strange readings - please see attached screenshots: in Screen1, I have normal operation and then the next reading doesn’t include Vrms and power. Also the temperature reading goes from a “normal” 21°C to a hellish 69°C!
Then in Screen2 for some reasons I have a message about “new config saved in EEPROM”
In Screen3 it starts behaving normally.

I have two main canditates for these issues now:

  • bad WiFi connectivity - I have -85 dBm signal, but I am already working on an upgrade
  • faulty AC/AC adapter - in particular in regards to the zero readings I got

I think 5V DC 2.4 A should be more than enough to power the setup…or not?

I would really appreciate your thoughts/tips.
Thank you

Welcome, Marco, to the OEM forum.

It is a problem with your ESP8266. It is sending random (I think) characters back to the emonTx, which the emonTx thinks is you using the ‘on-line’ calibration feature.

I do not have an ESP8266, so I cannot prove this.

There are three ways you can go:

  1. My colleague @borpin prefers to use a Pi Zero W instead of the ESP8266, so he will suggest you use that with a script to send the data, or
  2. You can disconnect the input to the emonTx serial from the ESP8266 - this is very confusingly labelled “Tx” on the emonTx’s UART connector, or
  3. You can delete the lines load_config() and 2 × config( .... ); - you will then not be able to change the r.f configuration nor the calibration ‘on-line’ - you will need to edit the source file, compile and reload. I cannot use platformio, it destroyed part of my system, so if you need more help with this, you will need to look to someone else.

Dear Robert,

many thanks for your feedback and help.
For a first try, I will go with disconnecting TX from the UART connector.
I wil update on the status.

p.s. great to know also Pi Zero W is a possibility, you guys really rock! I have just ordered another emonTX from the shop which I will use to monitor my PV production.
Thanks again

Thanks @Robert.Wall, means I have to remember how!

I think all I did was install the emonScripts when it asks if you want to continue you say no (otherwise you get a full emoncms) and then just run the emonhub.sh install script. The only change I made was to switch the branch to the Python3 branch as that was partly what I wanted to test.

You then need to configure emonhub, but it works pretty seamlessly.

This link will help

Ciao Robert

as promised here is my updae.
I received my second EmonTX, flashed continuous monitoring.
Then I flashed another NodeMCU with EmonESP FW and started monitoring solar inverter.
After a while I noticed the same issues (0 readings) and EEPROM writing.
I therefore disconnected the TX input and that solved my problem.

Thanks again

1 Like

It seems that this problem was anticipated with the emonESP module - the Tx pin from the emonESP is not connected to the header socket - but this was never documented nor mentioned to us moderators, so we were never aware of the potential problem.

It seems that it is only a problem when you use an ESP8266 not bought from the OEM Shop.

1 Like