Emoncms URI not acceptable. No controller 'dashboard'. (view/)

Starting today I am seeing this error on my server as well as other emoncms sites. Is anyone else seeing this…?

For example, when I open my emoncms (9.4) site and click on Feed API help in the upper right corner, I immediately get back this error:

URI not acceptable. No controller ‘api’. (/)

Same when looking at other people’s demo sites…

Clearing cache didn’t help, opening a new browser didn’t help, using a different machine that has never visited the sites didn’t help…

Am I missing something all of a sudden…?


I’ve seen the same error several times too, not sure why it’s occuring, but logging out and back in seemed to sort it.


Thanks Paul -

Logging in/out did not work for me, plus the public sites that I am hitting are having the same issue and no login is required.

I saw that error in a repeatable manner on my site.

I had attempted to access a sub-page which did not exist.

I had created a page called pi.html, but accessing it through the emoncms re-write URL woud not work for obvious reasons.
/pi.html is correct
/emoncms/pi.html gives exactly the same error.
So, unfortunately all I can suggest is trying to remove back to the /emoncms/ and work through the links again. It is possible that the software has updated to present a slightly different URL to that when the links were created.

Thanks ColdPenguin -

The issue is that I am seeing this error on sites that people have posted links to here on the forum that used to work but now do not. I do not think it is me inputting the incorrect URL since I am just clicking on their link, something has broken it would seem.

For example, if you read this: My Dashboard that's all folks (ish) :) Update V7.5 | Archived Forum

There is a link to his site: http://smitt1979.i234.me/emoncms/dashboard/view&id=13

And when I access it (I have been to it before) I get the following error:

URI not acceptable. No controller ‘dashboard’. (view/)

It does not matter which machine I use, or which browser…it no longer works and I am seeing the same issue with my own site.

There is a warning message hidden from the viewer when accessing the site listed:

Warning: file_exists(): open_basedir restriction in effect. File(/var/log/emoncms.log) is not within the allowed path(s): (/tmp:/var/services/tmp:/var/services/web:/var/services/homes) in /volume1/web/emoncms/Lib/EmonLogger.php on line 33

Warning: is_writable(): open_basedir restriction in effect. File(/var/log/emoncms.log) is not within the allowed path(s): (/tmp:/var/services/tmp:/var/services/web:/var/services/homes) in /volume1/web/emoncms/Lib/EmonLogger.php on line 38

Looking at the two lines of code, if you fancy testing, try setting $log_enabled=false in default.settings.php

If it works, then we need to work out what change has caused this to happen.
Ultimately, it looks like the php files here (extrapolating from EmonLogger.php path shown) are not within the paths shown so it is unlikely that will fix it, but it might move you on one error forwards

Hi Richard, No idea what is causing it, but I get the same error when trying to access that dashboard you just linked to, so it’s not you :wink:

There is also a message that appears at the top of the page - I guess this is coming from the remote server, and not from my Firefox browser as I am using Windows and wouldn’t expect to see some of these directory names ?

(/tmp:/var/services/tmp:/var/services/web:/var/services/homes) in /volume1/web/emoncms/Lib/EmonLogger.php on line 38

I also noticed that @smitt1979 that posted that dashboard is registered on this new forum, so hopefully by tagging him he will join this thread and the two of you can compare ideas

Try adding the root of your PHP files (I would guess at /var/www/html/emoncms perhaps) to the variable open_basedir in /etc/php/php.ini or /etc/php.ini depending on what you have in use.
It should be colon : seperated

Thanks Ian,

It is very weird, it just started happening for me out of the blue…