Community
OpenEnergyMonitor

Community

Emoncms : phpfina on shared hosting

Tags: #<Tag:0x00007f6e05ac8648> #<Tag:0x00007f6e05ac8580>

Have been playing with emoncms for a week now on my proper hosting account but used mysql as database for the feeds.
While trying the new solar app I stumbled on the fact you need the feeds to be ideally phpfina but …

am on a cpanel driven server (I do have root access as I’m the admin)
latest emoncms installed in /home/accountname/public_html/emon/…

When I want to add a phpfina feed I get an error (logical as that directory is not allowed, cpanel doesn’t allow to go out of the account name)

Is there a simple solution or do you need to recode ? If you would like people to use emoncms on their hosting (like me) I guess you will have to make relative paths to the account and not to root.

If I can be of any help, let me know …
thanks

ps : I can’t add a new tag like for example emoncms and phpfina …

now that the tag problem is solved (for now)

this is a real problem I have … a coder could please tell me how to solve this ? pleazzzzz :blush:

ok found the solution, stupid me … if installing on a shared server don’t forget this part :flushed:

  1. In your shared hosting /home/username folder create a folder called emoncmsdata to hold your emoncms feed data.
    (Note: NOT public_html as the data files should not be publicly accessible).
    Then create three folders within your emoncmsdata folder called: phpfiwa, phpfina and phptimeseries
  1. In the emoncms app directory make a copy of default_settings.php and call it settings.php.
    Open settings.php and enter your mysql username, password and database.
    In the feed_settings section uncomment the datadir definitions and set them to the location of each of the feed engine data folders on your system.
    In the ‘Other settings’ section, change the $log_filename location to:
    $log_filename = dirname(FILE).’/’ . ‘emoncms.log’;