Emoncms.org does not show input from local emoncms

Hello all! I’m trying to get my local emoncms on a Raspberry Pi 1 to send its input data (e.g. node = emonpi, key = power1, see below) to emonscms.org.

I followed the instructions about copying and pasting the API read/write key into local emoncms, but still no input fields appear in emonscms.org.

The emonhub.log file on the local emoncms shows:

2017-08-14 20:01:44,131 INFO emoncmsorg sending: https://emoncms.org/myip/set.json?apikey=E-M-O-N-C-M-S-A-P-I-K-E-Y
2017-08-14 20:02:13,906 INFO emoncmsorg sending: https://emoncms.org/input/bulk.json?apikey=E-M-O-N-C-M-S-A-P-I-K-E-Y&data=[]&sentat=1502740933
2017-08-14 20:02:14,161 DEBUG emoncmsorg acknowledged receipt with ‘ok’ from https://emoncms.org
2017-08-14 20:02:14,163 INFO emoncmsorg sending: https://emoncms.org/myip/set.json?apikey=E-M-O-N-C-M-S-A-P-I-K-E-Y

I’m not sure how to interpret this log file. Shouldn’t E-M-O-N-C-M-S-A-P-I-K-E-Y be replaced by the real API key and should data=[] be more like data=[value1, value2, value2]? Any help is appreciated!

Thanks in advance!!

Yes it should, and it must be your emoncms.org API key (not the one for your emoncms on your Pi). However, it will show as “E-M-O-N-C-M-S-A-P-I-K-E-Y” for security reasons.

You should be editing emonhub.conf via your web browser. Was this the guide that you followed? Because in that, and in the copy of emonhub.conf that I am looking at, the line you change to enter your API key is:

apikey = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If you post any configurations or log files etc, erase your APIkey before you post the file.

1 Like

I did indeed use that guide. I’m using the Raspberry Pi SD card image (release 07Nov16) and Emoncms Version low-write 9.8.7 | 2017.06.16. I put the emoncms.org API key in the emonhub.conf file through the browser and then clicked Save.

I won’t reveal my API key on this forum!

I followed all the instructions for troubleshooting (Troubleshooting - Guide | OpenEnergyMonitor), corrected the timezone and checked date and time (correct). Then upgraded emoncms to low-write 9.8.8 | 2017.07.18 and rebooted. it is still not working.

I think you need somebody who knows more about the emonPi to help you here. I fired up an emonPi that had previously never been connected to emoncms.org, and it worked straight away.

Does emoncms.org accept an input if you send the data (see the input API) from your browser?

Yes, sending data from my browser to emoncms.org (including the API key in the URL) works perfectly. See below for a screenshot of emoncms.org after sending data.

Hello @pmeinma, I think data=[] might be the issue, there needs to be data in there for anything to appear on emoncms.org.

Is your local emoncms running on the EmonPi or is it a separate emoncms installation?

Hi @TrystanLea, thanks for your reply. There is indeed data in local emoncms, running on my old Raspberry Pi 1 model B. Inputs: node = emonpi, keys = power1 & power2. I configured the feeds for the locally running Emoncms solarPV app, which works fine.

I used the Nov2016 RPi SDcard image.The data is received through MQTT, sent by NodeRED in the same RPi. The NodeRED MQTT output nodes use topics emon/emonpi/power1 and emon/emonpi/power2. Data is picked up perfectly by local emoncms. Does localcms expect more than just power values, e.g. T1, T2 like an EmonTX sends, in order to forward data to emoncms.org?

Hi, my problem stil hasn’t been solved. No data is sent from local EmonCMS to EmonCMS.org. Could you please follow up on my last answer. Thanks!