Community
OpenEnergyMonitor

Community

Emoncms.org billing


(jvda) #81

I would like to migrate multigraphs from emoncms.org to my local emoncms installation but I only succeeded in migrating the feeds (see Migrate multigraphs from emoncms.org to local emoncms installation).

Any idea how I can migrate the multigraphs ?
Jan.


(Trystan Lea) #82

Activating Emoncms Credit

Its now possible to access credit associated with past orders in emoncms.org. There’s a new section at the bottom of the user account page called ‘Activate Emoncms Credit’.

To access your credit:

  1. Enter the email address that you used to create your OpenEnergyMonitor shop account in the email entry box and click verify.
  2. An email will then be sent to your email account so that you can verify your identity and wish to link accounts.
  3. Navigate back to the user account page on emoncms.org and refresh, a list of past orders will now show in the Emoncms Credit section with credit associated with the account listed.
  4. Within 5 minutes the credit will apply to your balance and within 1 hour this balance will update on the graph.

Credit can now be bought in the OpenEnergyMonitor shop

Emoncms.org credit shop entry:
https://shop.openenergymonitor.com/emoncms-org-credit/

Negative balances accumulated during the last 3 months will be cleared and credit’s purchased before the 1st of July 2018 reissued in full during the morning, after 9am BST, of the 1st of July 2018.

There is not an immediate need to apply credit on or before the 1st of July. If accounts remain in negative credit after July 23rd (3 weeks) there will be an automated reminder email, there will be an initial 6 week grace period during which credit can be applied before posting is disabled.

I would also like to say thank you! With your support we are looking forward to being able to give emoncms.org and the self hosted emoncms more of the development and maintenance resource it needs to continue to make it a useful tool. Your support is really appreciated.

If you are self-hosting emoncms and would like to support ongoing development of this open source, freely downloadable software financially, please feel free to buy emoncms credit too.


(Robert Wall) #83

Is that 3 weeks plus 3 weeks, or 3 weeks plus 6 weeks?

After the initial period, what happens when credit runs out?


(Trystan Lea) #84

Thanks @Robert.Wall, 3 weeks + 3 weeks.

I mentioned before there would be a month before posting is disabled for accounts in negative credit, but I thought that given that we are in a transition period with the introduction of billing it would be better to allow more time at this point. If after this intial 6 weeks, an account is still in negative credit posting will be disabled but account access and data access will remain, including data download with the sync module etc.

  • At three months: account will be archived (the account can be recovered at this stage)
  • 6/12 months (to be confirmed): account will be permanently deleted.

(Mads Lykke) #85

Yesterday, I linked my emoncms.org account to my OEM shop account. After doing the email verification I’m no longer able to logon to my emoncms.org account; “Username does not exist”. PW recovery is not possible either. Any advice?


(Trystan Lea) #86

Hello @Lykke could you email me your username and email address to [email protected] and I will look into it for you


(Chris Cowap) #87

Dumb question maybe… and apologies if this has already been covered, and i cant see it…
but…
Is the Feed charging regime, per active Feed, or for the “Potential” for feeds with the kit connected ?
We have our own kit and also kit deployed for customers tied to our billing account.
Our own kit is currently set up to log from just two feeds (but has the potential for a lot more, and more was connected in the past), but it appears we are being charged for 13 on our account. (i.e. almost all the inputs on the active device)
Thanks
Chris


(Paul) #88

AFAICT neither, it is for all feeds present whether they are active or not. The term “feeds” refers to the storage feeds, not the input streams.

If you are being charged for 13 feeds, that would suggest you have 13 feeds listed on the feeds page, regardless of how many of those are “actively” being updated.


(Chris Cowap) #89

thanks Paul
looks like its caught up after a bit of a delay - once the accounts were all linked etc. etc.

showing 3 now - which matches whats “active”

many thanks

Chris


(Trystan Lea) #90

Emoncms.org Billing Update

Although 3 months later than planned we have started to send out notification emails to emoncms.org accounts still in negative credit.

Posting to accounts will be disabled for accounts still in negative credit for a period of 4 weeks or more starting on the 1st of November (just over a months time).

Accounts will be archived if still in negative credit for a period of 12 weeks or more starting on the 1st of January 2019.

We will also be starting to delete accounts that have been inactive for more than 1 year on the 1st of November 2018. There will be a separate email going out to inactive accounts to give prior warning.

Thanks to everyone who have bought emoncms credit over the last couple of months, its helping us really push emoncms development forwards, if you’ve been watching the emoncms github repository you will notice all the hard work @emrys in particular has been doing!


(snake) #91

Hi Trystan,

I’ve been a bit late looking into the emoncms account so I’ve just linked the purchase I made with my feeds. It now shows that I have enough credit but my feeds are not been updated.
Is there anything else I need to do in order to have them working again?
Thanks.


(Trystan Lea) #92

Hello @snake, thanks for linking your account. Disabling posting to accounts in negative balance has not yet started so I dont think its an issue on our end. Could you check your monitoring hardware?


(Frogmore42) #93

So, my account finally went negative a little while ago. I never got the email. I just happened to remember that now was about the time it was predicted to go negative based on the original balance I got for purchasing some products. So I went to the store to purchase some credits. I started a purchase on one device, but didn’t complete it, since that device doesn’t have all my saved information. A day later I got an email from the store asking if I wanted to complete the purchase. Since this device is the one with the info, I did.

That was a fine experience.

However, when it was done it said I could click on the link to activate my credit or wait till I got the mail confirmation to do it. There was no link on the shop page and not sure which link on the confirmation mail to click.

This was not a good experience. I don’t have a warm fuzzy post purchase satisfaction feeling of seeing my balance become positive.

While I have mostly moved on from emoncms (to influxdb and Grafana) I still want you all to be successful. I give the feedback as a customer and what I would like to see in a purchase transaction.


(Trystan Lea) #94

Thanks for the feedback @Frogmore42 your right experience could be improved. I see the credit has applied to your account and is shown in the balance but is not yet shown on the graph. I realise that since I extended the graph view port to show 6 months I dropped the resolution to 6 hours and so its not yet showing your updated balance. I will look into how to fix that.

I see you linked your account ok, perhaps we need to improve the wording to be clearer that no further credit activation is required after linking the emoncms.org account for the first time?


(Frogmore42) #95

Yeah, I had some issues linking the account the first time. There are separate accounts for the Store, the forum, and emoncms.org, which might be unavoidable, but is very confusing and nor very friendly.

I wasn’t particularly worried, but it is these seemingly little things that make it harder to use/like.

It was mostly the messaging at the store and in the email that was confusing.

Thanks